summaryrefslogtreecommitdiff
path: root/media-libs/ganv/ganv-1.8.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-02 13:12:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-02 13:12:50 +0100
commitb0378783c1929d283116fe183089c123dba5869c (patch)
treeefe69bfa7e38c36238f6e5a9341f6194b949e6f5 /media-libs/ganv/ganv-1.8.2.ebuild
parente374e165c2ee372e9c6d10860ea6ef47f180f6b2 (diff)
gentoo auto-resync : 02:10:2022 - 13:12:50
Diffstat (limited to 'media-libs/ganv/ganv-1.8.2.ebuild')
-rw-r--r--media-libs/ganv/ganv-1.8.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-libs/ganv/ganv-1.8.2.ebuild b/media-libs/ganv/ganv-1.8.2.ebuild
new file mode 100644
index 000000000000..18d6205e1dbc
--- /dev/null
+++ b/media-libs/ganv/ganv-1.8.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="A GTK+ widget for interactive graph-like environments"
+HOMEPAGE="https://drobilla.net/software/ganv.html"
+SRC_URI="https://download.drobilla.net/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+fdgl +graphviz introspection nls"
+
+RDEPEND="
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:2.4
+ x11-libs/gtk+:2
+ graphviz? ( media-gfx/graphviz[gtk2] )
+ introspection? (
+ app-text/yelp-tools
+ dev-libs/gobject-introspection:=[doctool]
+ )
+"
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ nls? ( virtual/libintl )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.8.2-make-intl-check-non-required.patch"
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature fdgl)
+ $(meson_feature graphviz)
+ $(meson_feature introspection gir)
+ $(meson_feature nls)
+ )
+
+ meson_src_configure
+}