summaryrefslogtreecommitdiff
path: root/media-libs/flickcurl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-05-07 00:00:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-05-07 00:00:56 +0100
commit7bcfea9c5e79a425a62a66bba477b9d3c0d7fdd0 (patch)
tree02bad8e4f1f060d4858a1a2ec3fc9404f0b7a197 /media-libs/flickcurl
parent43c2a85d4e20318dd3d35872e348707900870067 (diff)
gentoo auto-resync : 07:05:2024 - 00:00:56
Diffstat (limited to 'media-libs/flickcurl')
-rw-r--r--media-libs/flickcurl/Manifest4
-rw-r--r--media-libs/flickcurl/files/flickcurl-1.26-c99-configure.patch23
-rw-r--r--media-libs/flickcurl/files/flickcurl-1.26-c99.patch261
-rw-r--r--media-libs/flickcurl/flickcurl-1.26-r1.ebuild (renamed from media-libs/flickcurl/flickcurl-1.26.ebuild)11
4 files changed, 296 insertions, 3 deletions
diff --git a/media-libs/flickcurl/Manifest b/media-libs/flickcurl/Manifest
index 0f6bd49be79f..473a0e62e7ef 100644
--- a/media-libs/flickcurl/Manifest
+++ b/media-libs/flickcurl/Manifest
@@ -1,3 +1,5 @@
+AUX flickcurl-1.26-c99-configure.patch 869 BLAKE2B 89c32b9ed44fd85a632d133d9edc1a6ec20c360dd98923c5c191d07788a06865f4e0be54937f109fb011fffe7da9fbf379ae3159c45d673612e522f7d193b018 SHA512 207e2f1e3ea15e2020a217e8e41d4227d2d5fd69bc1d492d515dda6b33978e9f1f1e3fbc06eb172e3087af303e1e6802237727e8210105c1c573345507d0817a
+AUX flickcurl-1.26-c99.patch 4997 BLAKE2B 873db6661cd52e9655d97fe4c6ea104046d5df4049ddf0bc861d030d1dea6e52fae42bdb45c902b52a1deb105be78c8ba5a813409b8ed102bec7466af12fe7bf SHA512 9254b27a37221c1840249f9e020b350b4ec42ee12ac5df70fad8bb716340c53d4c4dd8839cdcc18410fe9d049161046ea04843e1a1db69203e35c78404da59fb
DIST flickcurl-1.26.tar.gz 1870073 BLAKE2B 2e14565ee076b5fd83987fc4aadc00ef1561714ea30cefef9d79260ebefa4856eca18ada5afdf6b02ad6e8ed293dd0872927346083d9eb8209bece1f456ea6bf SHA512 5ffdef58e67cbf99da2e8eefad57e845627703d5b22c85d5635557cd2df53e47e74d8e3387523495708c5cc8952c290da5c4d5f1e86bd482312fc7e46e9af6cd
-EBUILD flickcurl-1.26.ebuild 730 BLAKE2B 3285f748ecdca27b87fc8625dff0b55785e49b7a33c8ab0a2f3c012f55be8799de22fa284e3085849a0025181d9230f09ca7321364c3bb6ef708870682cf3460 SHA512 faf1d24c52bae9cb3115d5f16b88e380632b57c5ef3959f1ba18f33c4af1cfb63e8e77b5d14b6c0c9e58c926f68253cdb5ed0dffd7e6bbf95accd6c2280f0d5f
+EBUILD flickcurl-1.26-r1.ebuild 827 BLAKE2B bcd52d2037c50c5c4a23f680d75e88a333d3069b33d7cb703fbfe168e7a5905205559252ca9bb2c8b4996a005724ba24ea556a6fc86269b61032dba26aacecb9 SHA512 f9f3d79616729362a705fd2313554900bf48529ed481d1237826203247135e68acbc84cd4ad9bd09a44c0499cb710fb930c515b29d8d3c0462987246666dbd8b
MISC metadata.xml 353 BLAKE2B 9ca14bef082c611a8196f2dd2c4928f12a8a7c8bbd0690309a0fe3d11a04fb3fcb86d06580818c979a31c1213596f1e20b80da32792e8e4c3bba8d83c8dab454 SHA512 6f0ae948fc542b3d2a04b02eed1f4b30bb9ad5b359ec07f0aba4085e978184f8426b94c1f49a083214eeb21f018fee3696a63111ec53045f5c2b95c7e1b43c60
diff --git a/media-libs/flickcurl/files/flickcurl-1.26-c99-configure.patch b/media-libs/flickcurl/files/flickcurl-1.26-c99-configure.patch
new file mode 100644
index 000000000000..40fc7ff7b141
--- /dev/null
+++ b/media-libs/flickcurl/files/flickcurl-1.26-c99-configure.patch
@@ -0,0 +1,23 @@
+https://bugs.gentoo.org/899812
+https://github.com/dajobe/flickcurl/pull/43
+
+From 940019e2635f1bc21b712fadbf4f73ca45a26379 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Fri, 13 Jan 2023 09:33:08 +0100
+Subject: [PATCH] configure: Include <stdio.h> in vsnprintf check
+
+Avoid implicit declaration of vsnprintf for improved C99
+compatibility. Otherwise the configure script will fail
+to detect vsnprintf support with future compilers which
+do not support implicit function declarations.
+--- a/configure.ac
++++ b/configure.ac
+@@ -133,6 +133,7 @@ AC_LINK_IFELSE([AC_LANG_PROGRAM([[#ifdef HAVE_GETOPT_H
+ if test $ac_cv_func_vsnprintf = yes; then
+ AC_MSG_CHECKING(vsnprintf has C99 compatible return value)
+ AC_RUN_IFELSE([AC_LANG_SOURCE([[#include <stdarg.h>
++#include <stdio.h>
+ int is_c99(char *s, ...) {
+ char buffer[32];
+ va_list args;
+
diff --git a/media-libs/flickcurl/files/flickcurl-1.26-c99.patch b/media-libs/flickcurl/files/flickcurl-1.26-c99.patch
new file mode 100644
index 000000000000..ef2d48ca7ea0
--- /dev/null
+++ b/media-libs/flickcurl/files/flickcurl-1.26-c99.patch
@@ -0,0 +1,261 @@
+https://github.com/dajobe/flickcurl/pull/44
+
+From 96f263150cf025bdcf969fc9884cc90a466f54fb Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Mon, 6 May 2024 09:28:24 +0100
+Subject: [PATCH] Fix -Wimplicit-function-declaration
+
+GCC 14 and Clang 16 make this fatal by default.
+
+Bug: https://bugs.gentoo.org/927191
+--- a/src/activity.c
++++ b/src/activity.c
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+--- a/src/args.c
++++ b/src/args.c
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+--- a/src/blog.c
++++ b/src/blog.c
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+--- a/src/category.c
++++ b/src/category.c
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+--- a/src/collection.c
++++ b/src/collection.c
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+--- a/src/comments.c
++++ b/src/comments.c
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+--- a/src/contacts.c
++++ b/src/contacts.c
+@@ -24,6 +24,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+--- a/src/context.c
++++ b/src/context.c
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+--- a/src/exif.c
++++ b/src/exif.c
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+--- a/src/gallery.c
++++ b/src/gallery.c
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+--- a/src/group.c
++++ b/src/group.c
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+--- a/src/legacy-auth.c
++++ b/src/legacy-auth.c
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+--- a/src/members.c
++++ b/src/members.c
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+--- a/src/method.c
++++ b/src/method.c
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+--- a/src/note.c
++++ b/src/note.c
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+--- a/src/oauth.c
++++ b/src/oauth.c
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+--- a/src/perms.c
++++ b/src/perms.c
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+--- a/src/photo.c
++++ b/src/photo.c
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+ #include <ctype.h>
+
+ #ifdef HAVE_CONFIG_H
+--- a/src/photoset.c
++++ b/src/photoset.c
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+--- a/src/sha1.c
++++ b/src/sha1.c
+@@ -92,6 +92,7 @@ A million repetitions of "a"
+ #include <string.h>
+ #include <stdarg.h>
+ #include <stdint.h>
++#include <stdlib.h>
+
+ #include <flickcurl.h>
+ #include <flickcurl_internal.h>
+--- a/src/size.c
++++ b/src/size.c
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+--- a/src/stat.c
++++ b/src/stat.c
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+--- a/src/tags.c
++++ b/src/tags.c
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+--- a/src/ticket.c
++++ b/src/ticket.c
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+--- a/src/user_upload_status.c
++++ b/src/user_upload_status.c
+@@ -21,6 +21,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdarg.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_CONFIG_H
+ #include <config.h>
+
diff --git a/media-libs/flickcurl/flickcurl-1.26.ebuild b/media-libs/flickcurl/flickcurl-1.26-r1.ebuild
index 12c6109fe72b..d9b5b56ddfec 100644
--- a/media-libs/flickcurl/flickcurl-1.26.ebuild
+++ b/media-libs/flickcurl/flickcurl-1.26-r1.ebuild
@@ -17,11 +17,18 @@ IUSE="raptor"
RDEPEND="
>=net-misc/curl-7.10.0
>=dev-libs/libxml2-2.6.8:2
- raptor? ( media-libs/raptor:2 )"
+ raptor? ( media-libs/raptor:2 )
+"
DEPEND="${RDEPEND}"
BDEPEND="
dev-build/gtk-doc-am
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.26-c99-configure.patch
+ "${FILESDIR}"/${PN}-1.26-c99.patch
+)
src_prepare() {
default