summaryrefslogtreecommitdiff
path: root/media-libs/ffmpegsource/ffmpegsource-2.40.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-27 03:00:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-27 03:00:39 +0100
commitfe618c8b8c934661d2297b2aeb0615a48e787691 (patch)
tree24a8209687e0ff34205acd703b6b80e7c6897f81 /media-libs/ffmpegsource/ffmpegsource-2.40.ebuild
parent1d4cc2fdaa7a04ed1fe39b6cf1d892bd83bd8030 (diff)
gentoo auto-resync : 27:07:2022 - 03:00:38
Diffstat (limited to 'media-libs/ffmpegsource/ffmpegsource-2.40.ebuild')
-rw-r--r--media-libs/ffmpegsource/ffmpegsource-2.40.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-libs/ffmpegsource/ffmpegsource-2.40.ebuild b/media-libs/ffmpegsource/ffmpegsource-2.40.ebuild
new file mode 100644
index 000000000000..1ea646b97aa7
--- /dev/null
+++ b/media-libs/ffmpegsource/ffmpegsource-2.40.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+QA_PKGCONFIG_VERSION=$(ver_cut 1-2)
+inherit autotools
+
+DESCRIPTION="A libav/ffmpeg based source library for easy frame accurate access"
+HOMEPAGE="https://github.com/FFMS/ffms2"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/FFMS/ffms2.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/FFMS/ffms2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}"/ffms2-${PV}
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0/4"
+
+RDEPEND="
+ >=media-video/ffmpeg-2.4:=
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # Cheesy hack from autogen.sh
+ mkdir src/config || die
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}