summaryrefslogtreecommitdiff
path: root/media-libs/fcft
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-libs/fcft
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-libs/fcft')
-rw-r--r--media-libs/fcft/Manifest5
-rw-r--r--media-libs/fcft/fcft-3.0.0.ebuild90
-rw-r--r--media-libs/fcft/fcft-3.0.1.ebuild90
-rw-r--r--media-libs/fcft/metadata.xml18
4 files changed, 203 insertions, 0 deletions
diff --git a/media-libs/fcft/Manifest b/media-libs/fcft/Manifest
new file mode 100644
index 000000000000..1eff52b17475
--- /dev/null
+++ b/media-libs/fcft/Manifest
@@ -0,0 +1,5 @@
+DIST fcft-3.0.0.tar.gz 441458 BLAKE2B 9ff83691435953285f1b3f8b51dac7b17453a457eeb910f035e39c6fa3bb39098d3adbb7179f734261a4034e9ea8b034dd03a20ba0c364b7de2efe9b781dfdaa SHA512 fbf7ac7d777bdb530b90b79a0bd8b90d3f7ae8b099c2733304dbe89fbcc1a1a3493d1eac0478bcdee291d8c804da21461737fc3e34164637e86ff737023622b1
+DIST fcft-3.0.1.tar.gz 441493 BLAKE2B 79fe864edf04b21fe88fa167e3390836e5c7254710082312068ff4c39624508e086f4eed2ea5706b52421b2276a6f2d1f2211ff0b256112d989764e667c44fe2 SHA512 856bec504a253678a2962c0a7c5029e5fd3d26e305ca3fcae8d9df398bcc84a03e9d67522673d1f1bb0ec91606c0627d6ab4bf2780cbb5965a01c91e6f0aac89
+EBUILD fcft-3.0.0.ebuild 1923 BLAKE2B fd4c2103f14439e1f6efa03950724995e1a3b15847e42bea11e067d02ed98234f122071ca101c96fe5fcc3aeb41e851244355f847b7f61a450bf403033daead7 SHA512 35a61954dcb546d9cf90277e1e835133a72680d6cbcf2e6601b70eb4510943d6946c744e4bade1bb2e1fd20c0f09dca6fa01369771214c8ae44c968c040a932f
+EBUILD fcft-3.0.1.ebuild 1930 BLAKE2B 13d1c5b14964a7abb19d9951511753ebf61fe6dc868189e2a9a1fb9c690674d1b2664748e7b572de5d6230eca06eb66b57bf0f725a73a91705f8f3d71b0f9d0b SHA512 0a9b5eb6c76a1571a94ff256a58644b1595f7b00b87df6969681c5d6ccaf7cb64bf76a8a9446ff9223c973b8947e92a79c13ae134a882eac951bca0c882dc6b2
+MISC metadata.xml 631 BLAKE2B 464952a9c2b5959cbcb732323c54d57c4e67cb65efe87b4fe63b8369568531b0c6a0988990ea1756ee6012f81e6226600d638f2008fcdf452da36adeb5e204c0 SHA512 c2d704df7eeb25403bdbb7bd39c58c20d3c95dcf1c00051b8b558389344f9176fd4027349337ac7bb29249feefc997d0ef38e4ddc611d13a0c04a7880c048164
diff --git a/media-libs/fcft/fcft-3.0.0.ebuild b/media-libs/fcft/fcft-3.0.0.ebuild
new file mode 100644
index 000000000000..27380210cb01
--- /dev/null
+++ b/media-libs/fcft/fcft-3.0.0.ebuild
@@ -0,0 +1,90 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit meson python-any-r1
+
+DESCRIPTION="Simple library for font loading and glyph rasterization"
+HOMEPAGE="https://codeberg.org/dnkl/fcft"
+SRC_URI="https://codeberg.org/dnkl/fcft/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples +harfbuzz +libutf8proc test"
+REQUIRED_USE="
+ libutf8proc? ( harfbuzz )
+ examples? ( libutf8proc )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ media-libs/fontconfig
+ media-libs/freetype
+ x11-libs/pixman
+ examples? (
+ dev-libs/libutf8proc:=
+ dev-libs/wayland
+ )
+ harfbuzz? (
+ media-libs/harfbuzz:=
+ )
+ libutf8proc? (
+ dev-libs/libutf8proc:=
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ app-i18n/unicode-data
+ dev-libs/tllist
+ examples? (
+ dev-libs/wayland-protocols
+ )
+ test? (
+ dev-libs/check
+ harfbuzz? ( media-fonts/noto-emoji )
+ )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ app-text/scdoc
+ examples? (
+ dev-util/wayland-scanner
+ )
+"
+
+src_prepare() {
+ default
+
+ rm -r unicode || die "Failed removing vendored unicode-data"
+
+ sed -i "s;unicode/UnicodeData.txt;${EPREFIX}/usr/share/unicode-data/UnicodeData.txt;" \
+ meson.build || die "Failed changing UnicodeData.txt to system's copy"
+ sed -i "s;unicode/emoji-data.txt;${EPREFIX}/usr/share/unicode-data/emoji/emoji-data.txt;" \
+ meson.build || die "Failed changing emoji-data.txt to system's copy"
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature harfbuzz grapheme-shaping)
+ $(meson_feature libutf8proc run-shaping)
+ $(meson_use examples)
+ $(use test && meson_use harfbuzz test-text-shaping)
+ -Ddocs=enabled
+ -Dwerror=false
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ local DOCS=( CHANGELOG.md README.md )
+ meson_src_install
+
+ rm -r "${ED}"/usr/share/doc/${PN} || die
+
+ use examples && newbin "${BUILD_DIR}/example/example" fcft-example
+}
diff --git a/media-libs/fcft/fcft-3.0.1.ebuild b/media-libs/fcft/fcft-3.0.1.ebuild
new file mode 100644
index 000000000000..f09d1c8f6801
--- /dev/null
+++ b/media-libs/fcft/fcft-3.0.1.ebuild
@@ -0,0 +1,90 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit meson python-any-r1
+
+DESCRIPTION="Simple library for font loading and glyph rasterization"
+HOMEPAGE="https://codeberg.org/dnkl/fcft"
+SRC_URI="https://codeberg.org/dnkl/fcft/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="examples +harfbuzz +libutf8proc test"
+REQUIRED_USE="
+ libutf8proc? ( harfbuzz )
+ examples? ( libutf8proc )
+"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ media-libs/fontconfig
+ media-libs/freetype
+ x11-libs/pixman
+ examples? (
+ dev-libs/libutf8proc:=
+ dev-libs/wayland
+ )
+ harfbuzz? (
+ media-libs/harfbuzz:=
+ )
+ libutf8proc? (
+ dev-libs/libutf8proc:=
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ app-i18n/unicode-data
+ dev-libs/tllist
+ examples? (
+ dev-libs/wayland-protocols
+ )
+ test? (
+ dev-libs/check
+ harfbuzz? ( media-fonts/noto-emoji )
+ )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ app-text/scdoc
+ examples? (
+ dev-util/wayland-scanner
+ )
+"
+
+src_prepare() {
+ default
+
+ rm -r unicode || die "Failed removing vendored unicode-data"
+
+ sed -i "s;unicode/UnicodeData.txt;${EPREFIX}/usr/share/unicode-data/UnicodeData.txt;" \
+ meson.build || die "Failed changing UnicodeData.txt to system's copy"
+ sed -i "s;unicode/emoji-data.txt;${EPREFIX}/usr/share/unicode-data/emoji/emoji-data.txt;" \
+ meson.build || die "Failed changing emoji-data.txt to system's copy"
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature harfbuzz grapheme-shaping)
+ $(meson_feature libutf8proc run-shaping)
+ $(meson_use examples)
+ $(use test && meson_use harfbuzz test-text-shaping)
+ -Ddocs=enabled
+ -Dwerror=false
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ local DOCS=( CHANGELOG.md README.md )
+ meson_src_install
+
+ rm -r "${ED}"/usr/share/doc/${PN} || die
+
+ use examples && newbin "${BUILD_DIR}/example/example" fcft-example
+}
diff --git a/media-libs/fcft/metadata.xml b/media-libs/fcft/metadata.xml
new file mode 100644
index 000000000000..f209916337f0
--- /dev/null
+++ b/media-libs/fcft/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>arsen@aarsen.me</email>
+ <name>Arsen Arsenović</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="harfbuzz">Use <pkg>media-libs/harfbuzz</pkg> for grapheme
+ and run shaping</flag>
+ <flag name="libutf8proc">Use <pkg>media-libs/harfbuzz</pkg> and
+ <pkg>dev-libs/libutf8proc</pkg> for run shaping</flag>
+ </use>
+</pkgmetadata>