summaryrefslogtreecommitdiff
path: root/media-libs/exempi/exempi-2.4.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/exempi/exempi-2.4.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/exempi/exempi-2.4.2.ebuild')
-rw-r--r--media-libs/exempi/exempi-2.4.2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/media-libs/exempi/exempi-2.4.2.ebuild b/media-libs/exempi/exempi-2.4.2.ebuild
new file mode 100644
index 000000000000..aadfb65dbcf8
--- /dev/null
+++ b/media-libs/exempi/exempi-2.4.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools ltprune
+
+DESCRIPTION="Exempi is a port of the Adobe XMP SDK to work on UNIX"
+HOMEPAGE="https://libopenraw.freedesktop.org/wiki/Exempi"
+SRC_URI="https://libopenraw.freedesktop.org/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="2/3"
+KEYWORDS="alpha amd64 arm ~arm64 ~hppa ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd"
+IUSE="examples static-libs test"
+
+RDEPEND="
+ >=dev-libs/expat-2:=
+ virtual/libiconv
+ sys-libs/zlib:=
+"
+DEPEND="${RDEPEND}
+ sys-devel/autoconf-archive
+ sys-devel/gettext
+ test? ( >=dev-libs/boost-1.48 )
+"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${PN}-2.4.2-iconv.patch
+ cp /usr/share/gettext/config.rpath . || die
+ eautoreconf
+}
+
+src_configure() {
+ # Valgrind detection is "disabled" due to bug #295875
+ econf \
+ $(use_enable static-libs static) \
+ $(use_enable test unittest) \
+ VALGRIND=""
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+
+ if use examples; then
+ emake -C samples/source distclean
+ rm -f samples/{,source,testfiles}/Makefile*
+ insinto /usr/share/doc/${PF}/examples
+ doins -r samples/*
+ fi
+}