summaryrefslogtreecommitdiff
path: root/media-libs/esdl/esdl-1.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/esdl/esdl-1.3.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/esdl/esdl-1.3.1.ebuild')
-rw-r--r--media-libs/esdl/esdl-1.3.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/media-libs/esdl/esdl-1.3.1.ebuild b/media-libs/esdl/esdl-1.3.1.ebuild
new file mode 100644
index 000000000000..1ce1fdc89b8b
--- /dev/null
+++ b/media-libs/esdl/esdl-1.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils fixheadtails multilib
+
+DESCRIPTION="Erlang bindings for the SDL library"
+HOMEPAGE="http://esdl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/esdl/${P}.src.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ppc ppc64 ~x86"
+IUSE="image truetype"
+
+RDEPEND="
+ >=dev-lang/erlang-14[wxwidgets]
+ media-libs/libsdl[opengl]
+ image? ( media-libs/sdl-image )
+ truetype? ( media-libs/sdl-ttf )
+ virtual/opengl
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/rebar
+"
+
+src_compile() {
+ rebar compile || die
+}
+
+src_install() {
+ ERLANG_DIR="/usr/$(get_libdir)/erlang/lib"
+ ESDL_DIR="${ERLANG_DIR}/${P}"
+
+ find -name 'Makefile*' -exec rm -f '{}' \;
+
+ insinto ${ESDL_DIR}
+ doins -r ebin c_src include priv src
+}