summaryrefslogtreecommitdiff
path: root/media-libs/elles_icc_profiles
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/elles_icc_profiles
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/elles_icc_profiles')
-rw-r--r--media-libs/elles_icc_profiles/Manifest4
-rw-r--r--media-libs/elles_icc_profiles/elles_icc_profiles-20160501.0932.ebuild26
-rw-r--r--media-libs/elles_icc_profiles/metadata.xml26
3 files changed, 56 insertions, 0 deletions
diff --git a/media-libs/elles_icc_profiles/Manifest b/media-libs/elles_icc_profiles/Manifest
new file mode 100644
index 000000000000..bda7f688a839
--- /dev/null
+++ b/media-libs/elles_icc_profiles/Manifest
@@ -0,0 +1,4 @@
+DIST elles_icc_profiles-20160501.0932.tar.gz 334145 SHA256 480bcc09e8102f97fdfd1036933f1fcd4305d0e76bb555559f2099f7594935bc SHA512 10a3df45aadf923b2d7ff9c8ee906b000e70ad7d17c1a5005f889b49c6d57849c8befb5c4ed92748908bd5506789b6877c0504666de43c1a8621f646ab665e2f WHIRLPOOL 8d63f0c8db56a489e21bdb566d6aa85f9a3d29cffba0e043f650447f8b0fa6ab92c21fe9ca80f544070f6c6257257bcb288e4dbbb392160ce89ba69b35fcf1e1
+EBUILD elles_icc_profiles-20160501.0932.ebuild 601 SHA256 c52a6b07be0d05866a900c4a607878527493e2bde20b48f011dc052ccebe5120 SHA512 942d824839add0ecb64cf13b574b8a1f7a6e7748716e39552399e6e88121a50d0b2d06619f6a95db23030592b998d87d0fbc004809ff89c945da4a5b792913eb WHIRLPOOL aa4dc105eeb1df9d23b174cf362c8bbab9a6612a49307ce4a2da6c00a09b3caaf3eaeff05b1006d5640f1eace034d1e5cd77908f6f41d8b30405ae38f1c194d0
+MISC ChangeLog 968 SHA256 6dabdec830451d4718f45e2797ef48a90dc0f13799aae9ae4ed5c1985691629c SHA512 902a899d2df01b1b0f24c33f7322fb56e9df424b9b5e80cddfda1a584c5da8e97e007768f24a50152d11b44ede919ac8a31acfe87cdb12d9904ac953e7279d2d WHIRLPOOL 7285eba5772895a31e5c6cf8ad9efa9612a7a4fdd87182c79156a35cff23ba496e4d49e1e81c3de5b8b834d9d04a0413970f2fdaccf88e9982de8a82f543ab9c
+MISC metadata.xml 1155 SHA256 5b9f1797de6fb0851b247222d9f369dc8e5d9054074a4c298e5186eebee2a41f SHA512 3ab1772a6f2e06380dbd61e10926dda5ca7c80f1ae28cbf6e0f62e546c343eb8d9661bd6570c575b6f70cc83ea93e7df009a13eb4cecca4fcc63d4540bad37ae WHIRLPOOL 9efe627361a353c86d8341a3954ea1c7787796200074b0b3974300f7b03bc6d189002bf0249779a5330207cb415e1fcb251b6fc399aec6ba1eb3d8874f0a6448
diff --git a/media-libs/elles_icc_profiles/elles_icc_profiles-20160501.0932.ebuild b/media-libs/elles_icc_profiles/elles_icc_profiles-20160501.0932.ebuild
new file mode 100644
index 000000000000..8a7a71687d32
--- /dev/null
+++ b/media-libs/elles_icc_profiles/elles_icc_profiles-20160501.0932.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit versionator
+
+MY_PV="$(replace_version_separator 1 '-')EST"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Elle Stone's well-behaved RGB and grey ICC profiles"
+HOMEPAGE="http://ninedegreesbelow.com/photography/lcms-make-icc-profiles.html"
+SRC_URI="https://github.com/ellelstone/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="amd64"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ default
+
+ insinto /usr/share/color/icc/ellestone
+ doins profiles/*.icc
+}
diff --git a/media-libs/elles_icc_profiles/metadata.xml b/media-libs/elles_icc_profiles/metadata.xml
new file mode 100644
index 000000000000..bf2fc8f218e5
--- /dev/null
+++ b/media-libs/elles_icc_profiles/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>marecki@gentoo.org</email>
+ <name>Marek Szuba</name>
+ </maintainer>
+ <longdescription lang="en">
+ Elle Stone has developed LCMS-based ICC profile-making code which
+ makes a variety of RGB working space profiles, plus Gray profiles,
+ plus XYZ and LAB identity profiles. The code includes the most
+ commonly used RGB working space profiles (including ACES, ACEScg,
+ AdobeRGB1998, ProPhotoRGB, Rec.2020, and sRGB/Rec.709), plus
+ an assortment of less commonly used profiles. Each RGB working
+ space profile "family" is provided with the profile's standard Tone
+ Reproduction Curve ("TRC"), the linear gamma, gamma 1.8, and gamma
+ 2.2 TRCs, and the sRGB, LAB "L", and Rec709 TRCs, in both V2 and V4
+ versions.
+ The profiles are carefully checked for accuracy and are guaranteed
+ to be well-behaved, making them suitable for colour-managed image
+ editing.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">ellelstone/elles_icc_profiles</remote-id>
+ </upstream>
+</pkgmetadata>