summaryrefslogtreecommitdiff
path: root/media-libs/dumb/dumb-2.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /media-libs/dumb/dumb-2.0.3.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'media-libs/dumb/dumb-2.0.3.ebuild')
-rw-r--r--media-libs/dumb/dumb-2.0.3.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/media-libs/dumb/dumb-2.0.3.ebuild b/media-libs/dumb/dumb-2.0.3.ebuild
new file mode 100644
index 000000000000..7c509445721b
--- /dev/null
+++ b/media-libs/dumb/dumb-2.0.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+inherit cmake-multilib
+
+DESCRIPTION="Module/tracker based music format parser and player library"
+HOMEPAGE="https://github.com/kode54/dumb"
+SRC_URI="https://github.com/kode54/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="DUMB-0.9.3"
+SLOT="0/2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="allegro cpu_flags_x86_sse examples"
+
+RDEPEND="
+ allegro? (
+ media-libs/allegro:0[${MULTILIB_USEDEP}]
+ !media-libs/aldumb
+ )
+ examples? (
+ >=dev-libs/argtable-2
+ media-libs/libsdl2[sound]
+ )
+"
+
+DEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-pkg-config.patch
+)
+
+DOCS=(
+ CHANGELOG.md
+ DUMBFILE_SYSTEM.md
+ README.md
+ UPDATING_YOUR_PROJECTS.md
+)
+
+multilib_src_configure() {
+ local mycmakeargs=(
+ -DBUILD_ALLEGRO4=$(usex allegro)
+ -DBUILD_EXAMPLES=$(multilib_native_usex examples)
+ -DUSE_SSE=$(usex cpu_flags_x86_sse)
+ )
+ cmake_src_configure
+}