summaryrefslogtreecommitdiff
path: root/media-libs/dav1d/dav1d-0.9.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /media-libs/dav1d/dav1d-0.9.0.ebuild
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'media-libs/dav1d/dav1d-0.9.0.ebuild')
-rw-r--r--media-libs/dav1d/dav1d-0.9.0.ebuild61
1 files changed, 0 insertions, 61 deletions
diff --git a/media-libs/dav1d/dav1d-0.9.0.ebuild b/media-libs/dav1d/dav1d-0.9.0.ebuild
deleted file mode 100644
index f111b62346ef..000000000000
--- a/media-libs/dav1d/dav1d-0.9.0.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-SCM=""
-if [[ "${PV}" == "9999" ]]; then
- SCM="git-r3"
- EGIT_REPO_URI="https://code.videolan.org/videolan/dav1d"
-else
- KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
- SRC_URI="https://code.videolan.org/videolan/dav1d/-/archive/${PV}/${P}.tar.bz2"
-fi
-
-inherit ${SCM} meson-multilib
-
-DESCRIPTION="dav1d is an AV1 Decoder :)"
-HOMEPAGE="https://code.videolan.org/videolan/dav1d"
-
-LICENSE="BSD-2"
-SLOT="0/5"
-IUSE="+8bit +10bit +asm test xxhash"
-RESTRICT="!test? ( test )"
-
-ASM_DEPEND=">=dev-lang/nasm-2.15.05"
-BDEPEND="asm? (
- abi_x86_32? ( ${ASM_DEPEND} )
- abi_x86_64? ( ${ASM_DEPEND} )
- )
- xxhash? ( dev-libs/xxhash )
- "
-
-DOCS=( README.md doc/PATENTS THANKS.md )
-PATCHES=( "${FILESDIR}"/build-avoid-meson-s-symbols_have_underscore_prefix.patch )
-
-multilib_src_configure() {
- local -a bits=()
- use 8bit && bits+=( 8 )
- use 10bit && bits+=( 16 )
-
- local enable_asm
- if [[ ${MULTILIB_ABI_FLAG} == abi_x86_x32 ]]; then
- enable_asm=false
- else
- enable_asm=$(usex asm true false)
- fi
-
- local emesonargs=(
- -D bitdepths=$(IFS=,; echo "${bits[*]}")
- -D enable_asm=${enable_asm}
- -D enable_tests=$(usex test true false)
- -D xxhash_muxer=$(usex xxhash enabled disabled)
- )
- meson_src_configure
-}
-
-multilib_src_test() {
- if multilib_is_native_abi ; then
- meson_src_test
- fi
-}