summaryrefslogtreecommitdiff
path: root/media-libs/ctl/ctl-1.5.2-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-16 03:35:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-16 03:35:12 +0000
commitb62381b18b4bf2e919cbfbae11ebcad391e38e77 (patch)
tree0ea03896aa0bf5f376fdba3e25b9ecb8add6e65c /media-libs/ctl/ctl-1.5.2-r4.ebuild
parentda407288bb9fc771488c3fee13fc2f8561681e66 (diff)
gentoo auto-resync : 16:12:2022 - 03:35:12
Diffstat (limited to 'media-libs/ctl/ctl-1.5.2-r4.ebuild')
-rw-r--r--media-libs/ctl/ctl-1.5.2-r4.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/media-libs/ctl/ctl-1.5.2-r4.ebuild b/media-libs/ctl/ctl-1.5.2-r4.ebuild
new file mode 100644
index 000000000000..a63570fa6617
--- /dev/null
+++ b/media-libs/ctl/ctl-1.5.2-r4.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="AMPAS' Color Transformation Language"
+HOMEPAGE="https://github.com/ampas/CTL"
+SRC_URI="https://github.com/ampas/CTL/archive/${P}.tar.gz"
+S="${WORKDIR}/CTL-ctl-${PV}"
+
+LICENSE="AMPAS"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ~ppc64 x86"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="media-libs/ilmbase:=
+ media-libs/openexr:=
+ media-libs/tiff:=
+ !media-libs/openexr_ctl"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-Use-GNUInstallDirs-and-fix-PkgConfig-files-1.patch"
+ "${FILESDIR}/${P}-openexr-2.3.patch"
+ "${FILESDIR}/${P}-fix-to-build-with-gcc-11.patch"
+ "${FILESDIR}/${P}-install-dpx-library.patch"
+ "${FILESDIR}/${P}-fix-unit-tests.patch"
+)
+
+mycmakeargs=( -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}" )
+
+src_test() {
+ pushd "${BUILD_DIR}" >/dev/null || die
+ eninja check
+ popd >/dev/null || die
+}