summaryrefslogtreecommitdiff
path: root/media-libs/cimg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-22 10:09:44 +0000
commit09351e78166b5e864197c4456ebae3f89dd0bed9 (patch)
tree41a96399f56ed3aa399006871bfce4430db84aa2 /media-libs/cimg
parentc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (diff)
gentoo resync : 22.01.2019
Diffstat (limited to 'media-libs/cimg')
-rw-r--r--media-libs/cimg/Manifest2
-rw-r--r--media-libs/cimg/cimg-2.4.5.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/media-libs/cimg/Manifest b/media-libs/cimg/Manifest
index 88645ebb2c3a..404222bc54ce 100644
--- a/media-libs/cimg/Manifest
+++ b/media-libs/cimg/Manifest
@@ -1,3 +1,5 @@
DIST cimg-2.4.3.tar.gz 11074736 BLAKE2B 097da7f5b214470247296265950061acefec19a169139c65eb12b27ed8e1256b97f77d28deb910bb444f38d396e36c204c761437e8991421422e840fd7505a95 SHA512 3409fde40780d293051914ce988193063139f1f805e5b0205e829234944c76b877a2723dd7c616158bbb58238baf653a03f34d55052103286d3ee28a33136d15
+DIST cimg-2.4.5.tar.gz 11075045 BLAKE2B 6e9b9ccb5aa826526e9f9adbb964296a5f298772b696bad400a432bfd68e4b0048bbbb8591ac225393867aa2f00b708ea48c2858799522edcc2b021f3ba7fa7b SHA512 0a306ba4265a0e68d358e1ca54c597e80b43e72205de161d0971cd5837ca7d48322725d6ec129381e708a1d11fb5697884a5901ac753080fd8d8c08b80b28138
EBUILD cimg-2.4.3.ebuild 589 BLAKE2B 91b3c36c716f6e60a9652906cf7ef61bb2aab6ab56d7a40d6bcbccf924aab632886f6acc7d71c6d1ec5c8fc0e1c69d8e4c18258f45eee025f597587f247bb3fd SHA512 a1692a63111073a207c64e7e963af46be35d4b363eaf35f178cbf593391125d53232436a17a1e33426972e135452781887fc74eae68e36b5675c37520018bff3
+EBUILD cimg-2.4.5.ebuild 589 BLAKE2B ba27cc3c33dcecbd207d4a656893daa6cfafa4bf745da82a312075db4c23c7379348e1b37194afec9252c17c887cf342406c9fbc25dfd24119ca6f4b3085ba58 SHA512 1e6aba42be7cc3ce84384e49b2a2e59aafd0d0ffae2f07bed0fcdcc0dc9cd164c28b49f03af07ce15a0bbd25cdea4aee24fee4c4d425e58fac03ffa52b6d335e
MISC metadata.xml 386 BLAKE2B f7a15bc91bb1eb327b7a491dcf59b1ebadac6e36560bfbecaa07f7d3b189bfb86df12f1c2214b86cc83e70bce941f44a9424f13865c963ba38e9d992ca89075d SHA512 7273a9131bce0af6a2ae93e4893be6beadf25ed510dd3d32c267ea4400e0524929c49df92627fa3aa83ab539075d3404c7e5a2df77628261253aaced1216d59f
diff --git a/media-libs/cimg/cimg-2.4.5.ebuild b/media-libs/cimg/cimg-2.4.5.ebuild
new file mode 100644
index 000000000000..a3f01bc9ba22
--- /dev/null
+++ b/media-libs/cimg/cimg-2.4.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C++ template image processing toolkit"
+HOMEPAGE="https://cimg.eu/ https://github.com/dtschump/CImg"
+SRC_URI="https://github.com/dtschump/CImg/archive/v.${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CeCILL-2 CeCILL-C"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+S=${WORKDIR}/CImg-v.${PV}
+
+src_install() {
+ doheader CImg.h
+ dodoc README.txt
+
+ use doc && dodoc -r html
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}