summaryrefslogtreecommitdiff
path: root/media-libs/cimg/cimg-2.7.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-28 08:17:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-28 08:17:07 +0100
commit5a165c60b9b8c4847067cb83b4be7da785d01f93 (patch)
tree166b01591366d3479084ea774c888bc84aaa8d4f /media-libs/cimg/cimg-2.7.2.ebuild
parenta5b65c81168c90928784a1e92cda84ed5d6b9eb3 (diff)
gentoo resync : 28.09.2019
Diffstat (limited to 'media-libs/cimg/cimg-2.7.2.ebuild')
-rw-r--r--media-libs/cimg/cimg-2.7.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/media-libs/cimg/cimg-2.7.2.ebuild b/media-libs/cimg/cimg-2.7.2.ebuild
new file mode 100644
index 000000000000..a3f01bc9ba22
--- /dev/null
+++ b/media-libs/cimg/cimg-2.7.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="C++ template image processing toolkit"
+HOMEPAGE="https://cimg.eu/ https://github.com/dtschump/CImg"
+SRC_URI="https://github.com/dtschump/CImg/archive/v.${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="CeCILL-2 CeCILL-C"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+S=${WORKDIR}/CImg-v.${PV}
+
+src_install() {
+ doheader CImg.h
+ dodoc README.txt
+
+ use doc && dodoc -r html
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}