summaryrefslogtreecommitdiff
path: root/media-libs/cal3d/cal3d-0.11.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-libs/cal3d/cal3d-0.11.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-libs/cal3d/cal3d-0.11.0-r1.ebuild')
-rw-r--r--media-libs/cal3d/cal3d-0.11.0-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/media-libs/cal3d/cal3d-0.11.0-r1.ebuild b/media-libs/cal3d/cal3d-0.11.0-r1.ebuild
new file mode 100644
index 000000000000..40c49372639a
--- /dev/null
+++ b/media-libs/cal3d/cal3d-0.11.0-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils autotools
+
+DESCRIPTION="Cal3D is a skeletal based character animation library"
+HOMEPAGE="http://home.gna.org/cal3d"
+SRC_URI="http://download.gna.org/cal3d/sources/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc x86 ~x86-fbsd"
+IUSE="16bit-indices debug doc"
+
+DEPEND="doc? (
+ app-doc/doxygen
+ app-text/docbook-sgml-utils
+ )"
+RDEPEND=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-tests.patch \
+ "${FILESDIR}"/${P}-verbose.patch \
+ "${FILESDIR}"/${P}-gcc6.patch
+ sed -i \
+ -e "s:db2html:docbook2html:g" \
+ configure.in \
+ docs/Makefile.am \
+ || die "sed for doc failed"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable 16bit-indices)
+}
+
+src_compile() {
+ emake
+ if use doc; then
+ cd docs
+ emake doc-api
+ emake doc-guide
+ mkdir -p html/{guide,api}
+ mv *.{html,gif} html/guide/
+ mv api/html/* html/api/
+ fi
+}
+
+src_install() {
+ default
+ use doc && dohtml -r docs/html/api docs/html/guide
+}