summaryrefslogtreecommitdiff
path: root/media-libs/aubio
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /media-libs/aubio
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'media-libs/aubio')
-rw-r--r--media-libs/aubio/Manifest3
-rw-r--r--media-libs/aubio/aubio-0.4.8.ebuild126
-rw-r--r--media-libs/aubio/files/aubio-0.4.8-docdir.patch20
3 files changed, 149 insertions, 0 deletions
diff --git a/media-libs/aubio/Manifest b/media-libs/aubio/Manifest
index 3c4c4ba176b3..f1d894f61c3f 100644
--- a/media-libs/aubio/Manifest
+++ b/media-libs/aubio/Manifest
@@ -1,3 +1,6 @@
+AUX aubio-0.4.8-docdir.patch 1022 BLAKE2B 23c1a5060dcfd3e98d5464e50a4828807c482004dbc907fe708748f126b6b0341d98188d3d56dba6fdf800da548af5cb0d770ce8fb3e0fad5f1fb789523fed63 SHA512 1ab8b18daba024e2a2f7e605409176d1380bc3d4b6117ede7b9f480bf7bffa20d79fb2b160c976d9536ff5f57c3026c85a0228e7df63ac3a9b60135e855f045c
DIST aubio-0.4.7.tar.bz2 372173 BLAKE2B 544239b215dd87d4cf4a6ed6b5dd856411d0a3f1c3242e3e1077fa0780160785a9934884a1f0d0dc80fe21b1d417bc3800db59842ec300a4c29d75b7942cba05 SHA512 30c614f2b502b993df28d4746a99421fe0aada33c98c42ea19c271554b29b360cb4d4f6650c1b1da508da4bc341348c5944cb452f69b2bf354ca6348f84de260
+DIST aubio-0.4.8.tar.bz2 387933 BLAKE2B e30d0ce97360376edf8eba895dc3040157a139c843ef9d6bf0483ffb750916eaccf9e28b8d80dcc0034572cca4f08479e4db44468c96206ce7b60a2fa9600634 SHA512 e58b32beda36865a5243ec7ed4647cf96e3652a25fd319fc697c08f93487f895070dc66b830700b40b879220c2e3a53b8cdc255ce2e34770ba5e34b36a4f51b4
EBUILD aubio-0.4.7.ebuild 2450 BLAKE2B 975c2121ba3b505134e3b079e8654f77d16902e2fe6c31b158577922e3a2332909ff78f3eb04e16eef14039e1fdb4ead67a949eecc6f166f5efaf69a17bfc5c9 SHA512 7f26d97bf9de42e2429f797c3af73079a3105822ded2550fcf2852c5e6807fc4b60e9dd1688ef97aed1389161bde2544c94360f9fb82dfd92ba23d072ff90f8d
+EBUILD aubio-0.4.8.ebuild 2521 BLAKE2B d47d0ed05b3c03db6aa943ade15fa1715fda088e206d958ed257f451373353fa7d802dc3ee8c4223e3b16bd6151641d917af1faf32e125c8e12c47575b62073d SHA512 31883798430b6682e73f1ca2d05c5214aa54b0eb39f10886dd78278541487d6e610865af14509ab6621f87940e129894fd8229303b0c1f748b1dc2ada3222b5d
MISC metadata.xml 346 BLAKE2B 00429033f506bf3818f26f13062d21d0d04d8fc84185244615a09d008c5da6e350df5f32bdcba2c07103039ed64f802cc563a0ca8cd79e117741b947e421142d SHA512 ff3830c2d2322fabdb34458fd27c3e05ad825b1d707eee6150417e4c21480bdffbe4e639ff33a9914cc28189b91e970719326f065746f4241e186f7b27b168d1
diff --git a/media-libs/aubio/aubio-0.4.8.ebuild b/media-libs/aubio/aubio-0.4.8.ebuild
new file mode 100644
index 000000000000..f75c644d475e
--- /dev/null
+++ b/media-libs/aubio/aubio-0.4.8.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_OPTIONAL=1
+PYTHON_COMPAT=( python{2_7,3_{4,5,6,7}} )
+PYTHON_REQ_USE='threads(+)'
+inherit distutils-r1 waf-utils
+
+DESCRIPTION="Library for audio labelling"
+HOMEPAGE="https://aubio.org/"
+SRC_URI="https://aubio.org/pub/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0/5"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc double-precision examples ffmpeg fftw jack libav libsamplerate sndfile python test"
+
+RDEPEND="
+ ffmpeg? (
+ !libav? ( >=media-video/ffmpeg-2.6:0= )
+ libav? ( >=media-video/libav-9:0= )
+ )
+ fftw? ( sci-libs/fftw:3.0= )
+ jack? ( virtual/jack )
+ libsamplerate? ( media-libs/libsamplerate )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ )
+ sndfile? ( media-libs/libsndfile )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ app-text/txt2man
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}
+ ?? ( double-precision libsamplerate )
+"
+
+DOCS=( AUTHORS ChangeLog README.md )
+PYTHON_SRC_DIR="${S}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.4.8-docdir.patch
+)
+
+src_prepare() {
+ default
+ sed -e "s:doxygen:doxygen_disabled:" -i wscript || die
+
+ if ! use test; then
+ sed -e "/bld.*tests/d" -i wscript || die
+ fi
+}
+
+src_configure() {
+ python_setup
+ local mywafconfargs=(
+ --enable-complex
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable double-precision double)
+ $(use_enable fftw fftw3)
+ $(use_enable ffmpeg avcodec)
+ $(use_enable jack)
+ $(use_enable libsamplerate samplerate)
+ $(use_enable sndfile)
+ )
+ use double-precision || mywafconfargs+=( $(use_enable fftw fftw3f) )
+
+ waf-utils_src_configure "${mywafconfargs[@]}"
+
+ if use python ; then
+ cd "${PYTHON_SRC_DIR}" || die
+ distutils-r1_src_configure
+ fi
+}
+
+src_compile() {
+ waf-utils_src_compile --notests
+
+ if use doc; then
+ cd "${S}"/doc || die
+ emake dirhtml
+ fi
+
+ if use python ; then
+ cd "${PYTHON_SRC_DIR}" || die
+ distutils-r1_src_compile
+ fi
+}
+
+src_test() {
+ waf-utils_src_compile --alltests
+
+ if use python ; then
+ cd "${PYTHON_SRC_DIR}" || die
+ distutils-r1_src_test
+ fi
+}
+
+src_install() {
+ waf-utils_src_install
+
+ if use examples; then
+ # install dist_noinst_SCRIPTS from Makefile.am
+ dodoc -r examples
+ fi
+
+ if use python ; then
+ cd "${PYTHON_SRC_DIR}" || die
+ DOCS="" distutils-r1_src_install
+ newdoc python/README.md README.python
+ fi
+
+ if use doc; then
+ dodoc doc/*.txt
+ docinto html
+ dodoc -r doc/_build/dirhtml/.
+ fi
+
+ find "${ED}" -name "*.a" -delete || die
+}
diff --git a/media-libs/aubio/files/aubio-0.4.8-docdir.patch b/media-libs/aubio/files/aubio-0.4.8-docdir.patch
new file mode 100644
index 000000000000..58797995e3a6
--- /dev/null
+++ b/media-libs/aubio/files/aubio-0.4.8-docdir.patch
@@ -0,0 +1,20 @@
+--- aubio-0.4.8/wscript
++++ aubio-0.4.8/wscript
+@@ -548,7 +548,7 @@
+ source = 'doc/web.cfg',
+ target = '../doc/web/html/index.html',
+ cwd = 'doc')
+- bld.install_files( '${DATAROOTDIR}' + '/doc/libaubio-doc',
++ bld.install_files( '${DATAROOTDIR}' + '/doc/' + os.environ['PF'] + '/libaubio-doc',
+ bld.path.ant_glob('doc/web/html/**'),
+ cwd = bld.path.find_dir ('doc/web'),
+ relative_trick = True)
+@@ -564,7 +564,7 @@
+ ' `dirname ${SRC}` `dirname ${TGT}`',
+ source = 'doc/conf.py',
+ target = '../doc/_build/html/index.html')
+- bld.install_files( '${DATAROOTDIR}' + '/doc/libaubio-doc/sphinx',
++ bld.install_files( '${DATAROOTDIR}' + '/doc/' + os.environ['PF'] + '/libaubio-doc/sphinx',
+ bld.path.ant_glob('doc/_build/html/**'),
+ cwd = bld.path.find_dir('doc/_build/html'),
+ relative_trick = True)