summaryrefslogtreecommitdiff
path: root/media-libs/aribb24/aribb24-1.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-16 05:02:38 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-16 05:02:38 +0100
commitf1bc537f089cc8477a9a18db597cb349e1b00e91 (patch)
treec48eb730c43e5f35729fabbe5cb4bfbe4a1bc794 /media-libs/aribb24/aribb24-1.0.3.ebuild
parentcb3e8c6af7661fbcafdcacc7e0ecdfb610d098fa (diff)
gentoo resync : 16.06.2018
Diffstat (limited to 'media-libs/aribb24/aribb24-1.0.3.ebuild')
-rw-r--r--media-libs/aribb24/aribb24-1.0.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-libs/aribb24/aribb24-1.0.3.ebuild b/media-libs/aribb24/aribb24-1.0.3.ebuild
new file mode 100644
index 000000000000..6cfd472494c9
--- /dev/null
+++ b/media-libs/aribb24/aribb24-1.0.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Library for decoding ARIB STD-B24 subtitles"
+HOMEPAGE="https://github.com/nkoriyama/aribb24"
+SRC_URI="https://github.com/nkoriyama/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="media-libs/libpng:0="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}