summaryrefslogtreecommitdiff
path: root/media-libs/amf-headers/amf-headers-1.4.23.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-libs/amf-headers/amf-headers-1.4.23.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-libs/amf-headers/amf-headers-1.4.23.ebuild')
-rw-r--r--media-libs/amf-headers/amf-headers-1.4.23.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-libs/amf-headers/amf-headers-1.4.23.ebuild b/media-libs/amf-headers/amf-headers-1.4.23.ebuild
new file mode 100644
index 000000000000..f96ac72bc0e6
--- /dev/null
+++ b/media-libs/amf-headers/amf-headers-1.4.23.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/GPUOpen-LibrariesAndSDKs/AMF"
+else
+ SRC_URI="https://github.com/GPUOpen-LibrariesAndSDKs/AMF/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="The Advanced Media Framework (AMF) SDK"
+HOMEPAGE="https://github.com/GPUOpen-LibrariesAndSDKs/AMF"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+S="${WORKDIR}/AMF-${PV}"
+
+src_unpack() {
+ default
+
+ if [[ ${PV} == 9999 ]]; then
+ git-r3_src_unpack
+ fi
+}
+
+src_install() {
+ insinto "/usr/include/AMF"
+ doins -r "${S}/amf/public/include/"*
+}