summaryrefslogtreecommitdiff
path: root/media-gfx/yafaray/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:18:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-02 17:18:14 +0100
commit7b9f15840068dfaeea5684f8a1af1fe460dfa14c (patch)
tree112eea4497761c0227537330b58f9c7e0af3f9d8 /media-gfx/yafaray/files
parent0bff53119f08d677db6c1a991bd30741682a8a08 (diff)
gentoo resync : 02.06.2018
Diffstat (limited to 'media-gfx/yafaray/files')
-rw-r--r--media-gfx/yafaray/files/yafaray-3.3.0-blender-exporter-paths.patch15
-rw-r--r--media-gfx/yafaray/files/yafaray-3.3.0-respect-cflags.patch14
-rw-r--r--media-gfx/yafaray/files/yafaray-3.3.0-strip-debug-mode.patch12
3 files changed, 41 insertions, 0 deletions
diff --git a/media-gfx/yafaray/files/yafaray-3.3.0-blender-exporter-paths.patch b/media-gfx/yafaray/files/yafaray-3.3.0-blender-exporter-paths.patch
new file mode 100644
index 000000000000..9bf4f2b91f68
--- /dev/null
+++ b/media-gfx/yafaray/files/yafaray-3.3.0-blender-exporter-paths.patch
@@ -0,0 +1,15 @@
+diff --git a/work/Blender-Exporter-3.3.0/__init__.py b/work/Blender-Exporter-3.3.0/__init__.py
+index 85dc1c2..70a79e8 100644
+--- a/__init__.py
++++ b/__init__.py
+@@ -22,8 +22,8 @@ import sys
+ import os
+ import ctypes
+
+-PLUGIN_PATH = os.path.join(__path__[0], 'bin', 'yafaray-plugins')
+-BIN_PATH = os.path.join(__path__[0], 'bin')
++PLUGIN_PATH = '/usr/lib/yafaray-plugins'
++BIN_PATH = '/usr/bin'
+ YAF_ID_NAME = "YAFA_V3_RENDER"
+
+ # Version to be automatically populated during the cmake build process, getting the version from git tags
diff --git a/media-gfx/yafaray/files/yafaray-3.3.0-respect-cflags.patch b/media-gfx/yafaray/files/yafaray-3.3.0-respect-cflags.patch
new file mode 100644
index 000000000000..c22ff7e41ea6
--- /dev/null
+++ b/media-gfx/yafaray/files/yafaray-3.3.0-respect-cflags.patch
@@ -0,0 +1,14 @@
+diff --git a/work/Core-3.3.0/CMakeLists.txt b/work/Core-3.3.0/CMakeLists.txt
+index 75fd2c6..94c2502 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -219,9 +219,6 @@ if(NOT WIN32)
+ set(YAF_BINDINGS_RUBY_DIR ${YAF_LIB_DIR})
+ endif(NOT YAF_BINDINGS_RUBY_DIR)
+
+- # build flags
+- set(CMAKE_CXX_FLAGS "-Wall" CACHE STRING "Default compiler flags" FORCE)
+-
+ if(USER_RELEASE_OPTIMIZATION_FLAGS)
+ set(YAF_CXX_FLAGS_RELEASE ${USER_RELEASE_OPTIMIZATION_FLAGS})
+ else(USER_RELEASE_OPTIMIZATION_FLAGS)
diff --git a/media-gfx/yafaray/files/yafaray-3.3.0-strip-debug-mode.patch b/media-gfx/yafaray/files/yafaray-3.3.0-strip-debug-mode.patch
new file mode 100644
index 000000000000..3bdb4eeef361
--- /dev/null
+++ b/media-gfx/yafaray/files/yafaray-3.3.0-strip-debug-mode.patch
@@ -0,0 +1,12 @@
+diff --git a/work/Core-3.3.0/CMakeLists.txt b/work/Core-3.3.0/CMakeLists.txt
+index 75fd2c6..52c6b3d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -17,7 +17,6 @@ option(WITH_YAF_PY_BINDINGS "Enable the YafaRay Python bindings" ON)
+ option(WITH_YAF_RUBY_BINDINGS "Enable the YafaRay Ruby bindings" OFF)
+ option(WITH_OSX_ADDON "Enable the use of blender's included python lib on OSX platforms" OFF)
+ option(WITH_OpenCV "Build OpenCV image processing support" ON)
+-option(DEBUG_BUILD "Enable debug build mode" OFF)
+ option(EMBED_FONT_QT "Embed font for QT GUI (usefull for some buggy QT installations)" OFF)
+ option(FAST_MATH "Enable mathematic approximations to make code faster" ON)
+ option(FAST_TRIG "Enable trigonometric approximations to make code faster" ON)