summaryrefslogtreecommitdiff
path: root/media-gfx/xdot/xdot-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-11 05:38:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-11 05:38:21 +0100
commitd6260e76da0a436affc6839e470dd8619841cadc (patch)
treeca1df2a7c2e422ab51b16244374ae8ba94ab784e /media-gfx/xdot/xdot-9999.ebuild
parent6990d0600970cefe6aa2c17668f9028b08d23441 (diff)
gentoo auto-resync : 11:04:2023 - 05:38:21
Diffstat (limited to 'media-gfx/xdot/xdot-9999.ebuild')
-rw-r--r--media-gfx/xdot/xdot-9999.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/media-gfx/xdot/xdot-9999.ebuild b/media-gfx/xdot/xdot-9999.ebuild
index 03d06b61d665..6b9cdbea7cf7 100644
--- a/media-gfx/xdot/xdot-9999.ebuild
+++ b/media-gfx/xdot/xdot-9999.ebuild
@@ -1,7 +1,9 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..11} )
MY_PN=xdot.py
@@ -11,7 +13,7 @@ if [[ ${PV} = 9999* ]]; then
GIT_ECLASS="git-r3"
SRC_URI=""
else
- KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
MY_P="${MY_PN}-${PV}"
S="${WORKDIR}/${MY_P}"
SRC_URI="https://github.com/jrfonseca/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
@@ -25,14 +27,16 @@ HOMEPAGE="https://github.com/jrfonseca/xdot.py"
LICENSE="LGPL-2+"
SLOT="0"
-DEPEND="
+RDEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pycairo[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
media-gfx/graphviz
- test? ( x11-libs/gtk+:3 )
"
-RDEPEND="${DEPEND}"
+DEPEND="
+ ${RDEPEND}
+ test? ( x11-libs/gtk+:3[X] )
+"
run_test() {
cd tests && "${EPYTHON}" ../test.py *.dot graphs/*.gv