summaryrefslogtreecommitdiff
path: root/media-gfx/xdot/xdot-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-30 15:03:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-10-30 15:03:33 +0000
commitc9388864702fdd7b0b56c049eddb41bdb9054dcb (patch)
tree3595822471cd11e6f9f92565ab81ab9c5ee39c3f /media-gfx/xdot/xdot-9999.ebuild
parenta41f630aea0b4b71a6c9a088571f1eaaf8413d53 (diff)
gentoo auto-resync : 30:10:2022 - 15:03:33
Diffstat (limited to 'media-gfx/xdot/xdot-9999.ebuild')
-rw-r--r--media-gfx/xdot/xdot-9999.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/media-gfx/xdot/xdot-9999.ebuild b/media-gfx/xdot/xdot-9999.ebuild
index 646fd464d2bd..b0e3b6d5c63e 100644
--- a/media-gfx/xdot/xdot-9999.ebuild
+++ b/media-gfx/xdot/xdot-9999.ebuild
@@ -17,7 +17,7 @@ else
SRC_URI="https://github.com/jrfonseca/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
fi
-inherit ${GIT_ECLASS} distutils-r1
+inherit ${GIT_ECLASS} distutils-r1 virtualx
DESCRIPTION="Interactive viewer for Graphviz dot files"
HOMEPAGE="https://github.com/jrfonseca/xdot.py"
@@ -30,5 +30,15 @@ DEPEND="
dev-python/pycairo[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
media-gfx/graphviz
+ test? ( x11-libs/gtk+:3 )
"
RDEPEND="${DEPEND}"
+
+run_test() {
+ cd tests && "${EPYTHON}" ../test.py *.dot graphs/*.gv
+ return "${?}"
+}
+
+python_test() {
+ virtx run_test
+}