summaryrefslogtreecommitdiff
path: root/media-gfx/xdot/xdot-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-10 10:35:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-10 10:35:29 +0100
commit5067796b074450a155155c782ef4885c885cfb2b (patch)
tree68109e52982e612f48c05614ff09888cb33668ac /media-gfx/xdot/xdot-9999.ebuild
parent68d015b395b17126b8651edb61c80fca8c5968c1 (diff)
gentoo auto-resync : 10:09:2023 - 10:35:29
Diffstat (limited to 'media-gfx/xdot/xdot-9999.ebuild')
-rw-r--r--media-gfx/xdot/xdot-9999.ebuild9
1 files changed, 3 insertions, 6 deletions
diff --git a/media-gfx/xdot/xdot-9999.ebuild b/media-gfx/xdot/xdot-9999.ebuild
index 6b9cdbea7cf7..dc0e15d5f30b 100644
--- a/media-gfx/xdot/xdot-9999.ebuild
+++ b/media-gfx/xdot/xdot-9999.ebuild
@@ -2,9 +2,8 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
MY_PN=xdot.py
EGIT_REPO_URI="https://github.com/jrfonseca/${MY_PN}"
@@ -27,16 +26,14 @@ HOMEPAGE="https://github.com/jrfonseca/xdot.py"
LICENSE="LGPL-2+"
SLOT="0"
-RDEPEND="
+DEPEND="
dev-python/numpy[${PYTHON_USEDEP}]
dev-python/pycairo[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP}]
media-gfx/graphviz
-"
-DEPEND="
- ${RDEPEND}
test? ( x11-libs/gtk+:3[X] )
"
+RDEPEND="${DEPEND}"
run_test() {
cd tests && "${EPYTHON}" ../test.py *.dot graphs/*.gv