summaryrefslogtreecommitdiff
path: root/media-gfx/xdot/xdot-1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /media-gfx/xdot/xdot-1.1.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'media-gfx/xdot/xdot-1.1.ebuild')
-rw-r--r--media-gfx/xdot/xdot-1.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/media-gfx/xdot/xdot-1.1.ebuild b/media-gfx/xdot/xdot-1.1.ebuild
new file mode 100644
index 000000000000..8842ac3a99a5
--- /dev/null
+++ b/media-gfx/xdot/xdot-1.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+MY_PN=xdot.py
+EGIT_REPO_URI="https://github.com/jrfonseca/${MY_PN}"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-r3"
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~x86"
+ MY_P="${MY_PN}-${PV}"
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/jrfonseca/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+inherit ${GIT_ECLASS} distutils-r1
+
+DESCRIPTION="Interactive viewer for Graphviz dot files"
+HOMEPAGE="https://github.com/jrfonseca/xdot.py"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+
+DEPEND="
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ media-gfx/graphviz
+"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ default
+ [[ $PV = 9999* ]] && git-r3_src_unpack
+}
+
+src_prepare() {
+ eapply_user
+
+ # Don't require graphviz python(2) supprt, which xdot doesn't use. This allows xdot to support python3.
+ # For more info, see https://bugs.gentoo.org/643126
+ sed -i "/install_requires=\['graphviz'\],/d" setup.py || die
+}