summaryrefslogtreecommitdiff
path: root/media-gfx/xdot/xdot-0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/xdot/xdot-0.7.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/xdot/xdot-0.7.ebuild')
-rw-r--r--media-gfx/xdot/xdot-0.7.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/media-gfx/xdot/xdot-0.7.ebuild b/media-gfx/xdot/xdot-0.7.ebuild
new file mode 100644
index 000000000000..e67ac5185ee1
--- /dev/null
+++ b/media-gfx/xdot/xdot-0.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN=xdot.py
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Interactive viewer for Graphviz dot files"
+HOMEPAGE="https://github.com/jrfonseca/xdot.py"
+SRC_URI="https://github.com/jrfonseca/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.10:2[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ media-gfx/graphviz[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"