summaryrefslogtreecommitdiff
path: root/media-gfx/word_cloud/word_cloud-1.8.2.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-25 21:55:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-25 21:55:01 +0000
commitef596bcaa32d9c69d88a3451193cb242da803db1 (patch)
treed6084e886d9fb2f2bd064f937c0257aa1dfea7a6 /media-gfx/word_cloud/word_cloud-1.8.2.2-r1.ebuild
parent83ebb477861172671f6796999e016400b659d65f (diff)
gentoo auto-resync : 25:02:2023 - 21:55:01
Diffstat (limited to 'media-gfx/word_cloud/word_cloud-1.8.2.2-r1.ebuild')
-rw-r--r--media-gfx/word_cloud/word_cloud-1.8.2.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/media-gfx/word_cloud/word_cloud-1.8.2.2-r1.ebuild b/media-gfx/word_cloud/word_cloud-1.8.2.2-r1.ebuild
new file mode 100644
index 000000000000..e23142a10402
--- /dev/null
+++ b/media-gfx/word_cloud/word_cloud-1.8.2.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9,10,11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="A little word cloud generator in Python"
+HOMEPAGE="https://amueller.github.io/word_cloud/"
+SRC_URI="https://github.com/amueller/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~ulm/distfiles/${P}-python-3.11.patch.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" #808150
+
+RDEPEND="dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-fonts/droid"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.6.0-bundled-font.patch
+ "${WORKDIR}"/${P}-python-3.11.patch
+)