summaryrefslogtreecommitdiff
path: root/media-gfx/viewnior/viewnior-1.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/viewnior/viewnior-1.6.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/viewnior/viewnior-1.6.ebuild')
-rw-r--r--media-gfx/viewnior/viewnior-1.6.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/media-gfx/viewnior/viewnior-1.6.ebuild b/media-gfx/viewnior/viewnior-1.6.ebuild
new file mode 100644
index 000000000000..1efc547aee7e
--- /dev/null
+++ b/media-gfx/viewnior/viewnior-1.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit xdg-utils gnome2-utils autotools
+
+MY_PN=Viewnior
+DESCRIPTION="Fast and simple image viewer"
+HOMEPAGE="https://siyanpanayotov.com/project/viewnior/ https://github.com/hellosiyan/Viewnior"
+SRC_URI="https://github.com/hellosiyan/${MY_PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-libs/glib:2
+ media-gfx/exiv2
+ >=x11-libs/gtk+-2.20:2
+ x11-misc/shared-mime-info"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_PN}-${P}
+
+src_prepare() {
+ default
+
+ # fix for bug #454230
+ sed -r -i "s:(PKG_CHECK_MODULES):AC_CHECK_LIB([m],[cos])\n\n\1:" configure.ac
+
+ eautoreconf
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}