summaryrefslogtreecommitdiff
path: root/media-gfx/videorbits/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/videorbits/files
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/videorbits/files')
-rw-r--r--media-gfx/videorbits/files/videorbits-2.201-libpng15.patch30
-rw-r--r--media-gfx/videorbits/files/videorbits-2.205-fix-buildsystem.patch19
-rw-r--r--media-gfx/videorbits/files/videorbits-2.205-qa-implicit-declarations.patch23
3 files changed, 72 insertions, 0 deletions
diff --git a/media-gfx/videorbits/files/videorbits-2.201-libpng15.patch b/media-gfx/videorbits/files/videorbits-2.201-libpng15.patch
new file mode 100644
index 000000000000..f87132b0be44
--- /dev/null
+++ b/media-gfx/videorbits/files/videorbits-2.201-libpng15.patch
@@ -0,0 +1,30 @@
+--- videorbits-2.205/src/simple_png_read.c
++++ videorbits-2.205/src/simple_png_read.c
+@@ -92,7 +92,7 @@
+ return -1;
+ }
+
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ fprintf(stderr, "simple_png_read: error (internal)\n");
+ png_destroy_read_struct(&png_ptr, &info_ptr, &end_info);
+ fclose(fp);
+@@ -226,7 +226,7 @@
+ return -1;
+ }
+
+- if (setjmp(png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ fprintf(stderr, "simple_png_read_header: error\n");
+ png_destroy_read_struct(&png_ptr, &info_ptr, &end_info);
+ fclose(fp);
+--- videorbits-2.205/src/simple_png_write.c
++++ videorbits-2.205/src/simple_png_write.c
+@@ -18,6 +18,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <png.h>
++#include <zlib.h>
+
+ int simple_png_write_rgba(
+ char *filename,
diff --git a/media-gfx/videorbits/files/videorbits-2.205-fix-buildsystem.patch b/media-gfx/videorbits/files/videorbits-2.205-fix-buildsystem.patch
new file mode 100644
index 000000000000..8d2359232bc2
--- /dev/null
+++ b/media-gfx/videorbits/files/videorbits-2.205-fix-buildsystem.patch
@@ -0,0 +1,19 @@
+Fix installation paths.
+
+--- videorbits-2.205/images/Makefile.am
++++ videorbits-2.205/images/Makefile.am
+@@ -1,4 +1,4 @@
+-imagesdir = $(prefix)/images
+-images_DATA= v04.pgm v06.pgm
++images_dir = $(datadir)/videorbits/images
++images__DATA= v04.pgm v06.pgm
+
+
+--- videorbits-2.205/lookuptables/Makefile.am
++++ videorbits-2.205/lookuptables/Makefile.am
+@@ -1,3 +1,3 @@
+-lookuptablesdir = $(prefix)/lookuptables
+-lookuptables_DATA=powLookup22.txt powLookup47.txt Kodak_DCS260_response_function
++lookuptables_dir = $(datadir)/videorbits/lookuptables
++lookuptables__DATA=powLookup22.txt powLookup47.txt Kodak_DCS260_response_function
+
diff --git a/media-gfx/videorbits/files/videorbits-2.205-qa-implicit-declarations.patch b/media-gfx/videorbits/files/videorbits-2.205-qa-implicit-declarations.patch
new file mode 100644
index 000000000000..1e46ccf5651e
--- /dev/null
+++ b/media-gfx/videorbits/files/videorbits-2.205-qa-implicit-declarations.patch
@@ -0,0 +1,23 @@
+Fix implicit declarations caused by missing headers and
+failures caused by -Werror=format-security checks
+
+--- videorbits-2.205/src/pchirp2nocrop.c
++++ videorbits-2.205/src/pchirp2nocrop.c
+@@ -1,5 +1,6 @@
+ #include <stdlib.h>
+ #include <math.h>
++#include <string.h>
+ #include "PNMImageOffsetable.h"
+ #include "mat_util.h"
+ #include "boundingbox.h"
+--- videorbits-2.205/src/par.c
++++ videorbits-2.205/src/par.c
+@@ -111,7 +111,7 @@
+
+ /* - - Write file-type number - - */
+ sprintf(magic_number, "P%d\n", data_type);
+- fprintf(file_ptr, magic_number);
++ fprintf(file_ptr, "%s", magic_number);
+
+ /* - - put comments - - */ /* !!!!!! break up long comments */
+ fprintf(file_ptr, "# %s\n", comments);