summaryrefslogtreecommitdiff
path: root/media-gfx/svg2rlg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /media-gfx/svg2rlg
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'media-gfx/svg2rlg')
-rw-r--r--media-gfx/svg2rlg/Manifest3
-rw-r--r--media-gfx/svg2rlg/metadata.xml14
-rw-r--r--media-gfx/svg2rlg/svg2rlg-0.4.0.ebuild40
3 files changed, 57 insertions, 0 deletions
diff --git a/media-gfx/svg2rlg/Manifest b/media-gfx/svg2rlg/Manifest
new file mode 100644
index 000000000000..964ebe7ad0cc
--- /dev/null
+++ b/media-gfx/svg2rlg/Manifest
@@ -0,0 +1,3 @@
+DIST svg2rlg-0.4.0.tar.gz 504861 BLAKE2B bfd147d824d5a49f8621e705f6bdeefdaa571918db94afea8e839d048d2089a8c8ebf8e2763caa9866f55a7142e1bb3522b01f53eaf5b8343164a08ee0983ef3 SHA512 e3813a22784c2199a1df69574c64093347a153fa2b7a40e2f38f52e5d46d7ca8d6e8e3bbe54ab59381f6c7246352c016ff3e19b1278c6f2c8dcfbe8bd7017b12
+EBUILD svg2rlg-0.4.0.ebuild 950 BLAKE2B a17634c9d1bd786ba001686f2552ffb3a70a23cf1f246b98629d0b79e9c1319aac83f51dec503846d2a808ad3e5ba3d51004b2770b400d4fe7013c80a12da20c SHA512 e5ab448ae74dd1b0ddf07a16208937f38a587b1b466efb4d2aa6306e5b935924ffb0f4d17689cdfa06ceda2ca0282f68e4288b78109f74054722ec1bc4e9d23d
+MISC metadata.xml 435 BLAKE2B 959a42ebbe8dcec9cb5617c869387268b1fbac950540fd47b2e0121a36dcd763c269ea26d09d617843aa2d665412fd677d1833a42d98cf3e33d6c9cdc82c2e55 SHA512 8b83221cf8e9bc87dc62da2f4a18b85afca886b62cd3cc742ef258d7e6e462a9abd23cbd497ca6236100302d0b483cf07e0a2b98d45c8687fcb10ef615a18846
diff --git a/media-gfx/svg2rlg/metadata.xml b/media-gfx/svg2rlg/metadata.xml
new file mode 100644
index 000000000000..3e0a25ba5a56
--- /dev/null
+++ b/media-gfx/svg2rlg/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>nerdboy@gentoo.org</email>
+ <name>Steve Arnold</name>
+ </maintainer>
+ <longdescription lang="en">
+ A tool to convert from SVG to reportlab graphics objects.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">sarnold/svg2rlg</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-gfx/svg2rlg/svg2rlg-0.4.0.ebuild b/media-gfx/svg2rlg/svg2rlg-0.4.0.ebuild
new file mode 100644
index 000000000000..dd314bc752d8
--- /dev/null
+++ b/media-gfx/svg2rlg/svg2rlg-0.4.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Converts SVG files to PDFs or reportlab graphics"
+HOMEPAGE="https://github.com/sarnold/svg2rlg https://pypi.python.org/pypi/svg2rlg/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/sarnold/svg2rlg.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/sarnold/${PN}/archive/${PV}.tar.gz -> ${PN}-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="${PYTHON_DEPS}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/reportlab[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="!test? ( test )"
+
+python_test() {
+ nosetests -sx test_svg2rlg.py || die "Test failed with ${EPYTHON}"
+}