summaryrefslogtreecommitdiff
path: root/media-gfx/shotwell
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-22 20:51:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-22 20:51:36 +0100
commitdb80e2ef5b5a94d879a855799e86467f62293531 (patch)
treea08e6a23fe79165da2eeefacec6038382c1f89ff /media-gfx/shotwell
parent5772eab78c27d5409ea9e818a12abc9f686e7319 (diff)
gentoo auto-resync : 22:07:2023 - 20:51:35
Diffstat (limited to 'media-gfx/shotwell')
-rw-r--r--media-gfx/shotwell/Manifest2
-rw-r--r--media-gfx/shotwell/shotwell-0.32.2.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/media-gfx/shotwell/Manifest b/media-gfx/shotwell/Manifest
index 73ec406789f0..378d759031ce 100644
--- a/media-gfx/shotwell/Manifest
+++ b/media-gfx/shotwell/Manifest
@@ -1,3 +1,5 @@
DIST shotwell-0.32.1.tar.xz 35324252 BLAKE2B a8fd4195dcf495db8413586805f0d75d37759b62847c55dc8e81ed447c7d3c75e1f0f6b95f3982ee0712403b850d735962e4cd0f48ec41426e98c62555fdeb60 SHA512 1d487a0ea7ef0fb1b26d7c53b50e64b7d899bb9082744620dd421195b3ea90765633aac940695371d82fe5054f979e43cb587e726c4fa90712403ea9f60afcfe
+DIST shotwell-0.32.2.tar.xz 35327248 BLAKE2B e64c14fa8516dede11e5793f35328993755e83b893423f413a9419fe30fc8eebc26c61b34b259dcee1353dfdecb77f582c6e1a10a62e477032ea518d0e56af12 SHA512 3f502856ed0ad6dba18d696b67c940afe04b40130ba273bef8d2324301444c1c90e2762827061383785bb20f31b62a8657e9795b405f719254cec308f9430fca
EBUILD shotwell-0.32.1.ebuild 2192 BLAKE2B abf263e31c586649c40152986db6d887708982201212e00933b73c68cb264c4da14a9016e47ae2470d4e3c7b611efbeb9cd90a66c53e1d34ca87bb31169ea572 SHA512 eae7930ffa03d8c30bec87b82e7af7f1ec1c4503cb28606e8bcd32ddee1a7cab26efd6149d03d762da738a0805171165e0a6220dcdb1bf87c1b4ff34a3ca4088
+EBUILD shotwell-0.32.2.ebuild 2195 BLAKE2B dcac8ed19406167bb118a82a57dbb94626a95e42180cd9336e5decd60f089f4f0f8b55acecb2e7489619e1e5bf969a901d6bb8fccedb98415215db13c9c84969 SHA512 ba7664197c92e85ca81baa9710d5acbb3f2ffceb24c649cdd53ac1b925a8720728d747760ee59ef99cb90bf7b8112ec37a0730156c703c9c247934154e9f7f1a
MISC metadata.xml 794 BLAKE2B c1eb4a08828db11ba473fe21036201d3b57c2fa36a2bd39b18e7671cf5e4c42b2b9e82956456a0376a60bfc982d9af106577075d936dba3c0cb73947da46f427 SHA512 2c65cdf3c6d5a953b52ad81e0a85d1c1465f5c38c3475e5c1408baea0b14a053255e97c0efc560059c77c51dbe98b72a90c6164fe575e68cba3eb04d4774f490
diff --git a/media-gfx/shotwell/shotwell-0.32.2.ebuild b/media-gfx/shotwell/shotwell-0.32.2.ebuild
new file mode 100644
index 000000000000..63235d2bfa5c
--- /dev/null
+++ b/media-gfx/shotwell/shotwell-0.32.2.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson optfeature vala xdg
+
+DESCRIPTION="Open source photo manager for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Shotwell"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86"
+IUSE="opencv udev"
+
+DEPEND="
+ >=x11-libs/gtk+-3.22.0:3
+ >=dev-libs/glib-2.40.0:2
+ >=dev-libs/libgee-0.8.5:0.8=
+ >=net-libs/webkit-gtk-2.26:4.1
+ net-libs/libsoup:3.0
+ >=dev-libs/json-glib-0.7.6
+ >=dev-libs/libxml2-2.6.32:2
+ x11-libs/gdk-pixbuf:2
+ >=dev-db/sqlite-3.5.9:3
+ >=media-libs/gstreamer-1.20:1.0
+ >=media-libs/gst-plugins-base-1.20:1.0
+ >=media-libs/libgphoto2-2.5:=
+ udev? ( >=dev-libs/libgudev-145:= )
+ >=media-libs/gexiv2-0.12.3
+ >=media-libs/libraw-0.13.2:=
+ >=media-libs/libexif-0.6.16
+ app-crypt/libsecret
+ >=dev-libs/libportal-0.5:=[gtk]
+ media-libs/libwebp:=
+
+ >=app-crypt/gcr-3:0=[gtk]
+ x11-libs/cairo
+ opencv? ( >=media-libs/opencv-4.0.0:= )
+"
+RDEPEND="${DEPEND}
+ media-plugins/gst-plugins-gdkpixbuf:1.0
+ media-plugins/gst-plugins-meta:1.0
+"
+BDEPEND="
+ $(vala_depend)
+ dev-libs/appstream-glib
+ dev-libs/glib
+ dev-util/gdbus-codegen
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ net-libs/libsoup:3.0[vala]
+ media-libs/gexiv2[vala]
+ app-crypt/gcr:0[vala]
+"
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dunity_support=false
+ # -Dpublishers # In 0.30.2 all get compiled in anyways, even if restricted list, affects only runtime support
+ #trace
+ #measure
+ -Ddupe_detection=true
+ $(meson_use udev)
+ -Dinstall_apport_hook=false
+ $(meson_use opencv face_detection)
+ -Dfatal_warnings=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ optfeature "Enable support for the AVIF format" media-libs/libavif[gdk-pixbuf]
+ optfeature "Enable support for the HEIF format" media-libs/libheif[gdk-pixbuf]
+ optfeature "Enable support for the JPEG format" x11-libs/gdk-pixbuf[jpeg]
+ optfeature "Enable support for the TIFF format" x11-libs/gdk-pixbuf[tiff]
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}