summaryrefslogtreecommitdiff
path: root/media-gfx/sane-airscan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /media-gfx/sane-airscan
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'media-gfx/sane-airscan')
-rw-r--r--media-gfx/sane-airscan/Manifest4
-rw-r--r--media-gfx/sane-airscan/files/sane-airscan-0.99.27-makefile-fixes.patch56
-rw-r--r--media-gfx/sane-airscan/metadata.xml8
-rw-r--r--media-gfx/sane-airscan/sane-airscan-0.99.27.ebuild40
4 files changed, 108 insertions, 0 deletions
diff --git a/media-gfx/sane-airscan/Manifest b/media-gfx/sane-airscan/Manifest
new file mode 100644
index 000000000000..7215809211bd
--- /dev/null
+++ b/media-gfx/sane-airscan/Manifest
@@ -0,0 +1,4 @@
+AUX sane-airscan-0.99.27-makefile-fixes.patch 1913 BLAKE2B 1fe9fc148e3ac4f9928cb46a9ef35d2b94104dca39ffec09617d6143ce619c8739afad2811d7c5455ce4c0f190a88c68069a800607926009d2121c90aa8bca8b SHA512 8ed38a9debaf0520d7576f1874dd05b634a43825fb258fa3a0df0f3a93ebac6391d5a7e30ba460221d4174b7865f0372e91ff88f430baeca567dd4f633c0099a
+DIST sane-airscan-0.99.27.tar.gz 198418 BLAKE2B bcf2aff08feb90a65c10a4abaca67939874ad7c9376745b572f18ebfdaf7bff3e344d1379b00c73904a6892731a75f4632a90ea7c20f7cb4e30eab43413b829d SHA512 a35a92e26a4e3831f127e59bc520248abde8a7b304eb63ecf1d68092f51a8bc49bbc7503bead47ac84d0333d59ae0045d6d7a9f7b89d95f3ddfa2458f3781256
+EBUILD sane-airscan-0.99.27.ebuild 804 BLAKE2B 80b56646bdc0c4dfde9c0a0eb3cba9e3683ac0f7eea5f70d0ce57d0ea9da3ef4445b0d897b36b74ce4b6a31e9cc1e8a423507b0aaea1142e7c6e6ee99f86f353 SHA512 8c7861f806874899968160f0d2c6077785ea405f15ec440012e53ad9230b36fc72bd538b1c91f6207721f6397c05f748233bf0476006af813ca2c668ecdd2141
+MISC metadata.xml 245 BLAKE2B c146502191378e07b2d7d4d97bcb6daa8eb65f6c0b0d947b8214c19e5302fefc9921d9f8d13516c8bf31d9f642782d098a5d8aa67f45ed4fb33f65c25b1ef8ed SHA512 e901bb8274c666979c1a357a6681d5a0a0f73d5e1d6a4e87eb2f23b16e2ba28592b7d5bd9e2a3e37cf5aec66c159707deaf68619d0cda5e51e1ca98b73253c3a
diff --git a/media-gfx/sane-airscan/files/sane-airscan-0.99.27-makefile-fixes.patch b/media-gfx/sane-airscan/files/sane-airscan-0.99.27-makefile-fixes.patch
new file mode 100644
index 000000000000..204d1a5466a7
--- /dev/null
+++ b/media-gfx/sane-airscan/files/sane-airscan-0.99.27-makefile-fixes.patch
@@ -0,0 +1,56 @@
+From 8e9d059fa88606cba97291232ec16732f552bd48 Mon Sep 17 00:00:00 2001
+From: "Jason A. Donenfeld" <Jason@zx2c4.com>
+Date: Thu, 25 Nov 2021 14:24:25 +0100
+Subject: [PATCH] Makefile: abstract ar to $(AR) and remove tags from all
+
+Build systems need to be able to use a custom `ar` binary. Also, running
+ctags is generally not desirable for the default target.
+
+Signed-off-by: Jason A. Donenfeld <Jason@zx2c4.com>
+---
+Sent upstream as: https://github.com/alexpevzner/sane-airscan/pull/197
+
+ Makefile | 6 ++++--
+ 1 file changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 4c7e202..415d489 100644
+--- a/Makefile
++++ b/Makefile
+@@ -7,6 +7,7 @@
+ # ---- ------- -----------
+ # DESTDIR Destination directory for make install
+ # CC gcc C compiler
++# AR ar Archiver
+ # CPPFLAGS C preprocessor flags
+ # CFLAGS -O2 -g -W -Wall -Werror C compiler flags
+ # LDFLAGS Linker flags
+@@ -28,6 +29,7 @@
+ #
+
+ CC = gcc
++AR = ar
+ COMPRESS = gzip -n
+ CFLAGS += -O2 -g -W -Wall -Werror -pthread $(CPPFLAGS)
+ PKG_CONFIG = pkg-config
+@@ -101,7 +103,7 @@ $(OBJDIR)%.o: %.c Makefile airscan.h
+
+ .PHONY: all clean install man
+
+-all: tags $(BACKEND) $(DISCOVER) test test-decode test-multipart test-zeroconf test-uri
++all: $(BACKEND) $(DISCOVER) test test-decode test-multipart test-zeroconf test-uri
+
+ tags: $(SRC) airscan.h test.c test-decode.c test-multipart.c test-zeroconf.c test-uri.c
+ -ctags -R .
+@@ -113,7 +115,7 @@ $(DISCOVER): $(OBJDIR)discover.o $(LIBAIRSCAN)
+ $(CC) -o $(DISCOVER) discover.c $(CPPFLAGS) $(common_CFLAGS) $(LIBAIRSCAN) $(tools_LDFLAGS)
+
+ $(LIBAIRSCAN): $(OBJ) Makefile
+- ar cru $(LIBAIRSCAN) $(OBJ)
++ $(AR) cru $(LIBAIRSCAN) $(OBJ)
+
+ install: all
+ mkdir -p $(DESTDIR)/$(bindir)
+--
+2.34.1
+
diff --git a/media-gfx/sane-airscan/metadata.xml b/media-gfx/sane-airscan/metadata.xml
new file mode 100644
index 000000000000..78a9d6b02d0f
--- /dev/null
+++ b/media-gfx/sane-airscan/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>zx2c4@gentoo.org</email>
+<name>Jason A. Donenfeld</name>
+</maintainer>
+</pkgmetadata>
diff --git a/media-gfx/sane-airscan/sane-airscan-0.99.27.ebuild b/media-gfx/sane-airscan/sane-airscan-0.99.27.ebuild
new file mode 100644
index 000000000000..61f7cc9da931
--- /dev/null
+++ b/media-gfx/sane-airscan/sane-airscan-0.99.27.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="SANE backend for AirScan (eSCL) and WSD document scanners"
+HOMEPAGE="https://github.com/alexpevzner/sane-airscan"
+SRC_URI="https://github.com/alexpevzner/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ net-dns/avahi
+ net-libs/gnutls
+ dev-libs/libxml2
+ virtual/jpeg
+ media-libs/libpng
+"
+RDEPEND="${DEPEND}
+ media-gfx/sane-backends
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0.99.27-makefile-fixes.patch" )
+
+src_compile() {
+ emake \
+ CFLAGS="${CFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" \
+ AR="$(tc-getAR)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" COMPRESS= STRIP= install
+}