summaryrefslogtreecommitdiff
path: root/media-gfx/rawtherapee
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-19 17:39:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-19 17:39:35 +0000
commit9aa795a0179b29f7489bd04584bc8d2914da467b (patch)
treee628e5bd3419ed93917cff26165964b8d82064f6 /media-gfx/rawtherapee
parentfac3cfaabc3c46bf5cb7a2492197925c7c557b42 (diff)
gentoo auto-resync : 19:02:2024 - 17:39:34
Diffstat (limited to 'media-gfx/rawtherapee')
-rw-r--r--media-gfx/rawtherapee/Manifest2
-rw-r--r--media-gfx/rawtherapee/rawtherapee-5.10.ebuild81
2 files changed, 83 insertions, 0 deletions
diff --git a/media-gfx/rawtherapee/Manifest b/media-gfx/rawtherapee/Manifest
index 53034ae31a7a..0c7b5950c038 100644
--- a/media-gfx/rawtherapee/Manifest
+++ b/media-gfx/rawtherapee/Manifest
@@ -1,3 +1,5 @@
+DIST rawtherapee-5.10.tar.xz 16943724 BLAKE2B 2d1250a03f2902ffcff666514f9785036c808e9883957f674bfdb9545b2feac8f2313ab819e0cb64f39196bd3db36e8084b52bda6194de9197215824e695809c SHA512 79d6d54f90fec6006d3dff53aca00ccd385c398ebede2f06a223905d69e1045c6ab772bd5aca4bde01d9086c3c03183be22c0df521166b1af63b60bd7d0e1cfc
DIST rawtherapee-5.9.tar.xz 16219076 BLAKE2B 32039d6927eb4a4efbb49f3ad2bd019bd9f73c92a5e7125b7c560aaf7b6a42a5f1a2f67b24a713e4b255867539eda2bf63ea4e988453ec9634c917a11432a7fb SHA512 0d848a36293eb5cac3212910eaf1d011315269c6bbe780c4c2e5f91719721e25a7d1678a7e4453fa4a9694618978b04828612dc03e1d50cb9c11ad4d238e7ca8
+EBUILD rawtherapee-5.10.ebuild 1878 BLAKE2B d56c4a1932485ad4e1da8070b2c0ac2339331990402e6c6d96e2e2a491a21550ce9f6246aaf58d36c76043ce92db32b3ac3a999495145a9e7de4dfbc3aea6d7e SHA512 08e02868222ce2b20e0740988b33ef9b3c31b594d2fe5b515627638cf97c8f3cf17f103f2a80cd04a9634e89e48a04a2f1f4072e613ca1560874c6dd0176a0bf
EBUILD rawtherapee-5.9-r3.ebuild 1857 BLAKE2B 117f7db189d5d6226dcc6b0600fc5de2588de59821135d7464dea793cc961f453eb14ac702462714ee258e3439e598b07fb39b513c2b5cc29b5babba820fdf88 SHA512 84440a3813beef241f0b5502ed1e9f10bc53949ccc44b8a5c173fc6a96b004ad9322b5a7ea3650845bcd9b40a802ef058f4dee0b5681cae1730a19980fd545a2
MISC metadata.xml 245 BLAKE2B 4988fa1366a9b8a3769e503545339cdd493a0bdc362ca9237b158b94549de1f061477546b00fd3b21dc9325812423f7207071e22e3234d5c0b88c755197557d2 SHA512 e00be68ab9ad3acfce3d2d48721c47cf50e2c6358c9ceb45a2a23fc5303826ea26b9205ce4f230121c2e40c9c467367f2dc57863680899b21e8005034aa9118c
diff --git a/media-gfx/rawtherapee/rawtherapee-5.10.ebuild b/media-gfx/rawtherapee/rawtherapee-5.10.ebuild
new file mode 100644
index 000000000000..e4a69dd837de
--- /dev/null
+++ b/media-gfx/rawtherapee/rawtherapee-5.10.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=${P/_rc/-rc}
+inherit cmake flag-o-matic toolchain-funcs xdg-utils
+
+DESCRIPTION="A powerful cross-platform raw image processing program"
+HOMEPAGE="https://www.rawtherapee.com/"
+SRC_URI="https://rawtherapee.com/shared/source/${MY_P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="openmp tcmalloc"
+
+RDEPEND="
+ dev-cpp/atkmm:0
+ dev-cpp/cairomm:0
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:3.0
+ dev-cpp/pangomm:1.4
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/libsigc++:2
+ gnome-base/librsvg:2
+ media-gfx/exiv2:=
+ media-libs/lcms:2
+ media-libs/lensfun
+ media-libs/libcanberra[gtk3]
+ media-libs/libiptcdata
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:0=
+ media-libs/tiff:=
+ sci-libs/fftw:3.0=
+ sys-libs/zlib
+ x11-libs/gtk+:3
+ tcmalloc? ( dev-util/google-perftools )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ # upstream tested that "fast-math" give wrong results, so filter it
+ # https://bugs.gentoo.org/show_bug.cgi?id=606896#c2
+ filter-flags -ffast-math
+ # -Ofast enable "fast-math" both in gcc and clang
+ replace-flags -Ofast -O3
+ # In case we add an ebuild for klt we can (i)use that one,
+ # see http://cecas.clemson.edu/~stb/klt/
+ local mycmakeargs=(
+ -DOPTION_OMP=$(usex openmp)
+ -DDOCDIR=/usr/share/doc/${PF}
+ -DCREDITSDIR=/usr/share/${PN}
+ -DLICENCEDIR=/usr/share/${PN}
+ -DCACHE_NAME_SUFFIX=""
+ -DWITH_SYSTEM_KLT="off"
+ -DENABLE_TCMALLOC=$(usex tcmalloc)
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}