summaryrefslogtreecommitdiff
path: root/media-gfx/rawtherapee
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-09 00:01:06 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-09 00:01:06 +0000
commit9a754065ce56ab139449903367df82ccc14a7725 (patch)
treeaba2026be26b9905ddb573e3e79da8da2a812921 /media-gfx/rawtherapee
parent78ebdce6a16942c7081565472862ab6730321ee3 (diff)
gentoo auto-resync : 09:03:2023 - 00:01:06
Diffstat (limited to 'media-gfx/rawtherapee')
-rw-r--r--media-gfx/rawtherapee/Manifest1
-rw-r--r--media-gfx/rawtherapee/rawtherapee-5.9-r3.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/media-gfx/rawtherapee/Manifest b/media-gfx/rawtherapee/Manifest
index 2e511d4131b2..8843e2ac04d8 100644
--- a/media-gfx/rawtherapee/Manifest
+++ b/media-gfx/rawtherapee/Manifest
@@ -1,3 +1,4 @@
DIST rawtherapee-5.9.tar.xz 16219076 BLAKE2B 32039d6927eb4a4efbb49f3ad2bd019bd9f73c92a5e7125b7c560aaf7b6a42a5f1a2f67b24a713e4b255867539eda2bf63ea4e988453ec9634c917a11432a7fb SHA512 0d848a36293eb5cac3212910eaf1d011315269c6bbe780c4c2e5f91719721e25a7d1678a7e4453fa4a9694618978b04828612dc03e1d50cb9c11ad4d238e7ca8
EBUILD rawtherapee-5.9-r2.ebuild 1853 BLAKE2B 42fd47c79e57fc2631a53f60f63158560212ddb65a44148cdfe42ae8ddcc998799f7ef25a18e6cff4e0bb2231387c6ab01c8e842a48241de31d6aa104aafbff2 SHA512 2cc270b5adee8609f16ef8bc0c3779832466bb51e09cefa6bd5e6f63035b0ab8c0a52335421841cade91d502c2823ade52ce17d91cf7e41ea991fbf46cc3fe5f
+EBUILD rawtherapee-5.9-r3.ebuild 1857 BLAKE2B 117f7db189d5d6226dcc6b0600fc5de2588de59821135d7464dea793cc961f453eb14ac702462714ee258e3439e598b07fb39b513c2b5cc29b5babba820fdf88 SHA512 84440a3813beef241f0b5502ed1e9f10bc53949ccc44b8a5c173fc6a96b004ad9322b5a7ea3650845bcd9b40a802ef058f4dee0b5681cae1730a19980fd545a2
MISC metadata.xml 245 BLAKE2B 4988fa1366a9b8a3769e503545339cdd493a0bdc362ca9237b158b94549de1f061477546b00fd3b21dc9325812423f7207071e22e3234d5c0b88c755197557d2 SHA512 e00be68ab9ad3acfce3d2d48721c47cf50e2c6358c9ceb45a2a23fc5303826ea26b9205ce4f230121c2e40c9c467367f2dc57863680899b21e8005034aa9118c
diff --git a/media-gfx/rawtherapee/rawtherapee-5.9-r3.ebuild b/media-gfx/rawtherapee/rawtherapee-5.9-r3.ebuild
new file mode 100644
index 000000000000..199a2170f1e1
--- /dev/null
+++ b/media-gfx/rawtherapee/rawtherapee-5.9-r3.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=${P/_rc/-rc}
+inherit cmake flag-o-matic toolchain-funcs xdg-utils
+
+DESCRIPTION="A powerful cross-platform raw image processing program"
+HOMEPAGE="https://www.rawtherapee.com/"
+SRC_URI="https://rawtherapee.com/shared/source/${MY_P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~riscv x86"
+IUSE="openmp tcmalloc"
+
+RDEPEND="
+ dev-cpp/atkmm:0
+ dev-cpp/cairomm:0
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:3.0
+ dev-cpp/pangomm:1.4
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/libsigc++:2
+ gnome-base/librsvg:2
+ media-libs/lcms:2
+ media-libs/lensfun
+ media-libs/libcanberra[gtk3]
+ media-libs/libiptcdata
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:0=
+ media-libs/tiff:=
+ sci-libs/fftw:3.0=
+ sys-libs/zlib
+ x11-libs/gtk+:3
+ tcmalloc? ( dev-util/google-perftools )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+src_configure() {
+ # upstream tested that "fast-math" give wrong results, so filter it
+ # https://bugs.gentoo.org/show_bug.cgi?id=606896#c2
+ filter-flags -ffast-math
+ # -Ofast enable "fast-math" both in gcc and clang
+ replace-flags -Ofast -O3
+ # In case we add an ebuild for klt we can (i)use that one,
+ # see http://cecas.clemson.edu/~stb/klt/
+ local mycmakeargs=(
+ -DOPTION_OMP=$(usex openmp)
+ -DDOCDIR=/usr/share/doc/${PF}
+ -DCREDITSDIR=/usr/share/${PN}
+ -DLICENCEDIR=/usr/share/${PN}
+ -DCACHE_NAME_SUFFIX=""
+ -DWITH_SYSTEM_KLT="off"
+ -DENABLE_TCMALLOC=$(usex tcmalloc)
+ )
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}