summaryrefslogtreecommitdiff
path: root/media-gfx/rawtherapee/rawtherapee-5.8-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-18 09:41:23 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-18 09:41:23 +0000
commitd93ba9788a6ad1e5da2bf47e804456ded6d5c65c (patch)
treee01c10bcfe477cecf1770c8a8186e4a5344057b9 /media-gfx/rawtherapee/rawtherapee-5.8-r1.ebuild
parent7bf32644d8b70a318475609992d8e4853ec4ec0e (diff)
gentoo auto-resync : 18:12:2022 - 09:41:22
Diffstat (limited to 'media-gfx/rawtherapee/rawtherapee-5.8-r1.ebuild')
-rw-r--r--media-gfx/rawtherapee/rawtherapee-5.8-r1.ebuild85
1 files changed, 0 insertions, 85 deletions
diff --git a/media-gfx/rawtherapee/rawtherapee-5.8-r1.ebuild b/media-gfx/rawtherapee/rawtherapee-5.8-r1.ebuild
deleted file mode 100644
index 0a49b2a46441..000000000000
--- a/media-gfx/rawtherapee/rawtherapee-5.8-r1.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-MY_P=${P/_rc/-rc}
-inherit cmake flag-o-matic toolchain-funcs xdg-utils
-
-DESCRIPTION="A powerful cross-platform raw image processing program"
-HOMEPAGE="https://www.rawtherapee.com/"
-SRC_URI="https://rawtherapee.com/shared/source/${MY_P}.tar.xz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~riscv x86"
-IUSE="openmp tcmalloc"
-
-RDEPEND="
- dev-cpp/atkmm:=
- dev-cpp/cairomm:=
- dev-cpp/glibmm:=
- dev-cpp/gtkmm:3.0
- dev-cpp/pangomm:=
- dev-libs/expat
- dev-libs/glib:=
- dev-libs/libsigc++:2
- gnome-base/librsvg
- media-libs/lcms:2
- media-libs/lensfun
- media-libs/libcanberra[gtk3]
- media-libs/libiptcdata
- media-libs/libjpeg-turbo:=
- media-libs/libpng:0=
- media-libs/tiff:=
- sci-libs/fftw:3.0=
- sys-libs/zlib
- x11-libs/gtk+:3
- tcmalloc? ( dev-util/google-perftools )"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}/RT_5.8_fix_crop.patch"
- "${FILESDIR}/RT_5.8_glibc234.patch"
-)
-
-pkg_pretend() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-pkg_setup() {
- [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
-}
-
-src_configure() {
- # upstream tested that "fast-math" give wrong results, so filter it
- # https://bugs.gentoo.org/show_bug.cgi?id=606896#c2
- filter-flags -ffast-math
- # -Ofast enable "fast-math" both in gcc and clang
- replace-flags -Ofast -O3
- # In case we add an ebuild for klt we can (i)use that one,
- # see http://cecas.clemson.edu/~stb/klt/
- local mycmakeargs=(
- -DOPTION_OMP=$(usex openmp)
- -DDOCDIR=/usr/share/doc/${PF}
- -DCREDITSDIR=/usr/share/${PN}
- -DLICENCEDIR=/usr/share/${PN}
- -DCACHE_NAME_SUFFIX=""
- -DWITH_SYSTEM_KLT="off"
- -DENABLE_TCMALLOC=$(usex tcmalloc)
- )
- cmake_src_configure
-}
-
-pkg_postinst() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- xdg_icon_cache_update
- xdg_desktop_database_update
-}