summaryrefslogtreecommitdiff
path: root/media-gfx/rawtherapee/rawtherapee-5.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-28 08:17:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-28 08:17:07 +0100
commit5a165c60b9b8c4847067cb83b4be7da785d01f93 (patch)
tree166b01591366d3479084ea774c888bc84aaa8d4f /media-gfx/rawtherapee/rawtherapee-5.7.ebuild
parenta5b65c81168c90928784a1e92cda84ed5d6b9eb3 (diff)
gentoo resync : 28.09.2019
Diffstat (limited to 'media-gfx/rawtherapee/rawtherapee-5.7.ebuild')
-rw-r--r--media-gfx/rawtherapee/rawtherapee-5.7.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/media-gfx/rawtherapee/rawtherapee-5.7.ebuild b/media-gfx/rawtherapee/rawtherapee-5.7.ebuild
new file mode 100644
index 000000000000..48b8dca754d1
--- /dev/null
+++ b/media-gfx/rawtherapee/rawtherapee-5.7.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=${P/_rc/-rc}
+inherit cmake-utils flag-o-matic toolchain-funcs xdg-utils
+
+DESCRIPTION="A powerful cross-platform raw image processing program"
+HOMEPAGE="https://www.rawtherapee.com/"
+SRC_URI="https://rawtherapee.com/shared/source/${MY_P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="openmp"
+
+RDEPEND="
+ dev-libs/expat
+ dev-libs/libsigc++:2
+ media-libs/lcms:2
+ media-libs/lensfun
+ media-libs/libcanberra[gtk3]
+ media-libs/libiptcdata
+ media-libs/libpng:0
+ media-libs/tiff:0
+ sci-libs/fftw:3.0
+ sys-libs/zlib
+ virtual/jpeg:0
+ x11-libs/gtk+:3"
+DEPEND="${RDEPEND}
+ dev-cpp/gtkmm:3.0
+ gnome-base/librsvg"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if use openmp ; then
+ tc-has-openmp || die "Please switch to an openmp compatible compiler"
+ fi
+}
+
+src_configure() {
+ # upstream tested that "fast-math" give wrong results, so filter it
+ # https://bugs.gentoo.org/show_bug.cgi?id=606896#c2
+ filter-flags -ffast-math
+ # -Ofast enable "fast-math" both in gcc and clang
+ replace-flags -Ofast -O3
+ # In case we add an ebuild for klt we can (i)use that one,
+ # see http://cecas.clemson.edu/~stb/klt/
+ local mycmakeargs=(
+ -DOPTION_OMP=$(usex openmp)
+ -DDOCDIR=/usr/share/doc/${PF}
+ -DCREDITSDIR=/usr/share/${PN}
+ -DLICENCEDIR=/usr/share/${PN}
+ -DCACHE_NAME_SUFFIX=""
+ -DWITH_SYSTEM_KLT="off"
+ )
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}