summaryrefslogtreecommitdiff
path: root/media-gfx/raw-thumbnailer/raw-thumbnailer-0.2.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
commit02e2208f46f4e2c00fb9743cbc47350bdd233bfa (patch)
tree132dd60828854db4f65f30f9230f43d9602507ff /media-gfx/raw-thumbnailer/raw-thumbnailer-0.2.1-r1.ebuild
parent8be70107efbb417f839292165ee39d07a062046f (diff)
gentoo resync : 16.01.2018
Diffstat (limited to 'media-gfx/raw-thumbnailer/raw-thumbnailer-0.2.1-r1.ebuild')
-rw-r--r--media-gfx/raw-thumbnailer/raw-thumbnailer-0.2.1-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/media-gfx/raw-thumbnailer/raw-thumbnailer-0.2.1-r1.ebuild b/media-gfx/raw-thumbnailer/raw-thumbnailer-0.2.1-r1.ebuild
new file mode 100644
index 000000000000..8d3bedb4b406
--- /dev/null
+++ b/media-gfx/raw-thumbnailer/raw-thumbnailer-0.2.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A lightweight and fast raw image thumbnailer"
+HOMEPAGE="https://github.com/erlendd/raw-thumbnailer"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/libopenraw-0.1:=[gtk]
+ x11-libs/gtk+:2
+ !media-gfx/gnome-raw-thumbnailer"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog )
+PATCHES=(
+ "${FILESDIR}"/${P}-libopenraw.patch # bug 609972
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}