summaryrefslogtreecommitdiff
path: root/media-gfx/pngquant/pngquant-2.12.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /media-gfx/pngquant/pngquant-2.12.6.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'media-gfx/pngquant/pngquant-2.12.6.ebuild')
-rw-r--r--media-gfx/pngquant/pngquant-2.12.6.ebuild17
1 files changed, 12 insertions, 5 deletions
diff --git a/media-gfx/pngquant/pngquant-2.12.6.ebuild b/media-gfx/pngquant/pngquant-2.12.6.ebuild
index ded2693e8e4a..2e645d7f52f3 100644
--- a/media-gfx/pngquant/pngquant-2.12.6.ebuild
+++ b/media-gfx/pngquant/pngquant-2.12.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -22,14 +22,21 @@ RDEPEND="
sys-libs/zlib:=
lcms? ( media-libs/lcms:2 )
"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
RESTRICT="!test? ( test )"
PATCHES=( "${FILESDIR}"/${PN}-2.12.2-respect-CFLAGS.patch )
+pkg_pretend() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} != binary ]] && use openmp && tc-check-openmp
+}
+
src_prepare() {
default
@@ -45,7 +52,7 @@ src_configure() {
--with-libimagequant \
$(use debug && echo --enable-debug) \
$(use_enable cpu_flags_x86_sse2 sse) \
- $(use openmp && tc-has-openmp && echo --with-openmp) \
+ $(use openmp && echo --with-openmp) \
$(use_with lcms lcms2) \
CFLAGS="${CFLAGS} ${CPPFLAGS}" \
LDFLAGS="${LDFLAGS}"