summaryrefslogtreecommitdiff
path: root/media-gfx/plantuml/plantuml-1.2024.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-07 12:30:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-07 12:30:41 +0100
commit3c7931f8c6c90aa813912d87c684d742e0c29a05 (patch)
treefe70317ba47324f028de7df8ce1d13394263950f /media-gfx/plantuml/plantuml-1.2024.4.ebuild
parent7336b11bd5bd8f1cc6d445b150a6c466736c3d9d (diff)
gentoo auto-resync : 07:04:2024 - 12:30:41
Diffstat (limited to 'media-gfx/plantuml/plantuml-1.2024.4.ebuild')
-rw-r--r--media-gfx/plantuml/plantuml-1.2024.4.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-gfx/plantuml/plantuml-1.2024.4.ebuild b/media-gfx/plantuml/plantuml-1.2024.4.ebuild
new file mode 100644
index 000000000000..141aa1f0ffdc
--- /dev/null
+++ b/media-gfx/plantuml/plantuml-1.2024.4.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="source"
+inherit java-pkg-2 java-ant-2 desktop xdg
+
+DESCRIPTION="Draw UML diagrams using a simple and human readable text description"
+HOMEPAGE="https://plantuml.com"
+SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+ >=dev-java/ant-1.10.14-r1:0
+ media-gfx/graphviz"
+
+EANT_BUILD_TARGET="dist"
+EANT_GENTOO_CLASSPATH="ant"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+ use source && java-pkg_dosrc src/*
+
+ make_desktop_entry plantuml PlantUML
+}