summaryrefslogtreecommitdiff
path: root/media-gfx/plantuml/plantuml-1.2022.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /media-gfx/plantuml/plantuml-1.2022.1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'media-gfx/plantuml/plantuml-1.2022.1.ebuild')
-rw-r--r--media-gfx/plantuml/plantuml-1.2022.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/media-gfx/plantuml/plantuml-1.2022.1.ebuild b/media-gfx/plantuml/plantuml-1.2022.1.ebuild
new file mode 100644
index 000000000000..8ba5d39fd289
--- /dev/null
+++ b/media-gfx/plantuml/plantuml-1.2022.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="source"
+inherit java-pkg-2 java-ant-2 desktop xdg
+
+DESCRIPTION="Draw UML diagrams using a simple and human readable text description"
+HOMEPAGE="https://plantuml.com"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+ dev-java/ant-core:0
+ media-gfx/graphviz"
+
+EANT_BUILD_TARGET="dist"
+EANT_GENTOO_CLASSPATH="ant-core"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+ use source && java-pkg_dosrc src/*
+
+ make_desktop_entry plantuml PlantUML
+}