summaryrefslogtreecommitdiff
path: root/media-gfx/plantuml/plantuml-1.2019.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /media-gfx/plantuml/plantuml-1.2019.13.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'media-gfx/plantuml/plantuml-1.2019.13.ebuild')
-rw-r--r--media-gfx/plantuml/plantuml-1.2019.13.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-gfx/plantuml/plantuml-1.2019.13.ebuild b/media-gfx/plantuml/plantuml-1.2019.13.ebuild
new file mode 100644
index 000000000000..be646991f7bf
--- /dev/null
+++ b/media-gfx/plantuml/plantuml-1.2019.13.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+JAVA_PKG_IUSE="source"
+inherit java-pkg-2 java-ant-2 desktop xdg
+
+DESCRIPTION="Draw UML diagrams using a simple and human readable text description"
+HOMEPAGE="http://plantuml.com"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8"
+
+RDEPEND=">=virtual/jre-1.8
+ dev-java/ant-core:0
+ >=media-gfx/graphviz-2.26.3"
+
+EANT_BUILD_TARGET="dist"
+EANT_GENTOO_CLASSPATH="ant-core"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ java-pkg_dolauncher ${PN} --jar ${PN}.jar
+ use source && java-pkg_dosrc src/*
+
+ make_desktop_entry plantuml PlantUML
+}