summaryrefslogtreecommitdiff
path: root/media-gfx/photivo/photivo-0_pre20131115.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/photivo/photivo-0_pre20131115.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/photivo/photivo-0_pre20131115.ebuild')
-rw-r--r--media-gfx/photivo/photivo-0_pre20131115.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/media-gfx/photivo/photivo-0_pre20131115.ebuild b/media-gfx/photivo/photivo-0_pre20131115.ebuild
new file mode 100644
index 000000000000..f258013d4bf7
--- /dev/null
+++ b/media-gfx/photivo/photivo-0_pre20131115.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit qt4-r2
+
+DESCRIPTION="Photo processor for RAW and Bitmap images"
+HOMEPAGE="http://www.photivo.org"
+SRC_URI="https://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gimp"
+
+RDEPEND="dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ || ( virtual/jpeg:62 media-libs/jpeg:62 )
+ media-gfx/exiv2
+ media-libs/tiff
+ media-libs/libpng
+ media-libs/cimg
+ media-libs/lcms:2
+ >=media-libs/lensfun-0.2.8-r1
+ sci-libs/fftw:3.0
+ media-libs/liblqr
+ media-gfx/graphicsmagick[q16,-lcms]
+ gimp? ( media-gfx/gimp )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${PN}-${PV/0_pre/}
+
+src_prepare() {
+ # remove ccache dependency and fix lensfun header path
+ local File
+ for File in $(find "${S}" -type f); do
+ if grep -sq ccache ${File}; then
+ sed -e 's/ccache//' -i "${File}"
+ fi
+ if grep -sq "lensfun.h" ${File}; then
+ sed -e 's/lensfun\.h/lensfun\/lensfun.h/' -i ${File}
+ fi
+ done
+
+ # useless check (no pkgconfig file is provided)
+ sed -e "/PKGCONFIG += CImg/d" \
+ -i photivoProject/photivoProject.pro || die
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local config="WithSystemCImg"
+ if use gimp ; then
+ config+=" WithGimp"
+ fi
+
+ eqmake4 "CONFIG+=${config}"
+}
+
+src_install() {
+ qt4-r2_src_install
+
+ if use gimp; then
+ exeinto $(gimptool-2.0 --gimpplugindir)/plug-ins
+ doexe ptGimp
+ doexe "mm extern photivo.py"
+ fi
+}