summaryrefslogtreecommitdiff
path: root/media-gfx/optipng
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-04 04:00:13 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-04 04:00:13 +0000
commit686478aa70361c355e5d9b528af40f2b863e69b4 (patch)
treed468b32b7c3e708ea5b97e44edcbb738bfc51dbf /media-gfx/optipng
parent9d352bec7c48de973d3fa345f92f733fe075f19a (diff)
gentoo auto-resync : 04:11:2023 - 04:00:13
Diffstat (limited to 'media-gfx/optipng')
-rw-r--r--media-gfx/optipng/Manifest2
-rw-r--r--media-gfx/optipng/optipng-0.7.8.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/media-gfx/optipng/Manifest b/media-gfx/optipng/Manifest
index 2566629b0eaf..2a618017f785 100644
--- a/media-gfx/optipng/Manifest
+++ b/media-gfx/optipng/Manifest
@@ -1,3 +1,5 @@
DIST optipng-0.7.7.tar.gz 2329555 BLAKE2B af3e1c806522282ccbf9325c0b49f61a30d24b8e2db2dd8ec316a312d0dea595cbb6e8b5b38ef5ea90f1efe14244b81f85f88e11e7334fdd4b91b43b6dae8e7d SHA512 c33b7650143ab39944d2c066e07e10273c37024c5bfe7c00475bfb513af96afa081ff388164845d426d3bce624c0282dee574fa150e963f18d3683d821030280
+DIST optipng-0.7.8.tar.gz 3294014 BLAKE2B b6d40335adadd1cef2b200c913d09eda67970910945904b26befb8de6f070eee99baa42b1ef4cfd6ad37759a528b7ad39a00fe5ea1b5e268c2d8385041d9f129 SHA512 def47bb2898d9409773df55a99fec84af2a26b58192127ac4624b2ff504762bc4735b5b945e788174eac695cc81be1b062088b42683b9c889dc42f94431210c3
EBUILD optipng-0.7.7-r1.ebuild 1247 BLAKE2B 2c3df0c4d0d8a60718ff621f0d608da4a983d509b091641f2001b7816d5739ee0327ffc01a2d2f35f686f02033b0ea9f0f1439a86f7899002b047f41d99cf5a4 SHA512 dc396a46df9eecd18ef77f24adbf3af51e6f65d836fc14aa1db456429e32dee635c11e788c34bd8ac97895beb251bc3c73e44eef856317b6c19dda1bd5c67dfc
+EBUILD optipng-0.7.8.ebuild 1124 BLAKE2B 9abc5d3959394154ebb9087f790c4e0e0c3f870bddb2a4f111638d55b19fae07755e9798f5ae70b496ade0fa24c28216171e70f262de71fb6727dae61938b69a SHA512 2e8e8d159bab44d189bc9b553fe95e047997419f1685a31c790197ed690087bd789632135b69957528a8ebe12ab5558ecae1c9b9de9884850d59e5b30d97c377
MISC metadata.xml 327 BLAKE2B 745b2e0c0f28536549ac19222922e33d7dc69089b79274930fd58ea6e9f4d706c2a6eb78e7d2d8b2cd96c6d9a1252fe35794e08b7254eeb8b3379aca6b9a1856 SHA512 cc024af7ee59e0e27b30963434fde5f655943cc51d20e74912881a43087564f28df0fc4bf93651e479451fd381d57f321b491097b408e45e601394a0507c3b07
diff --git a/media-gfx/optipng/optipng-0.7.8.ebuild b/media-gfx/optipng/optipng-0.7.8.ebuild
new file mode 100644
index 000000000000..8127c0351499
--- /dev/null
+++ b/media-gfx/optipng/optipng-0.7.8.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Compress PNG files without affecting image quality"
+HOMEPAGE="https://optipng.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="sys-libs/zlib
+ media-libs/libpng:0="
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS.txt README.txt )
+
+src_prepare() {
+ rm -R third_party/{libpng,zlib} || die
+ find . -type d -name build -exec rm -R {} + || die
+
+ sed -i \
+ -e 's/^#if defined AT_FDCWD/#if (defined(AT_FDCWD) \&\& !(defined(__SVR4) \&\& defined(__sun)))/' \
+ src/optipng/ioutil.c || die
+
+ tc-export CC AR RANLIB
+ export LD="$(tc-getCC)"
+
+ eapply_user
+}
+
+src_configure() {
+ ./configure \
+ --with-system-libpng \
+ --with-system-zlib \
+ || die "configure failed"
+}
+
+src_compile() {
+ emake -C src/optipng
+}
+
+src_install() {
+ einstalldocs
+
+ dodoc doc/*.txt
+ docinto html
+ dodoc doc/*.html
+ doman src/${PN}/man/${PN}.1
+
+ dobin src/${PN}/${PN}
+}