summaryrefslogtreecommitdiff
path: root/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /media-gfx/openvdb/openvdb-5.2.0-r1.ebuild
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'media-gfx/openvdb/openvdb-5.2.0-r1.ebuild')
-rw-r--r--media-gfx/openvdb/openvdb-5.2.0-r1.ebuild105
1 files changed, 0 insertions, 105 deletions
diff --git a/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild b/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild
deleted file mode 100644
index a176389a2a05..000000000000
--- a/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8,9} )
-
-inherit cmake flag-o-matic python-single-r1
-
-DESCRIPTION="Library for the efficient manipulation of volumetric data"
-HOMEPAGE="https://www.openvdb.org"
-SRC_URI="https://github.com/AcademySoftwareFoundation/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="abi3-compat abi4-compat +abi5-compat doc python test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
- ^^ ( abi3-compat abi4-compat abi5-compat )
-"
-
-RDEPEND="
- dev-libs/boost:=
- dev-libs/c-blosc:=
- dev-libs/jemalloc:=
- dev-libs/log4cplus:=
- media-libs/glfw
- media-libs/openexr:=
- sys-libs/zlib:=
- x11-libs/libXcursor
- x11-libs/libXi
- x11-libs/libXinerama
- x11-libs/libXrandr
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-libs/boost:=[python?,${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- ')
- )
-"
-
-DEPEND="
- ${RDEPEND}
- dev-cpp/tbb
-"
-
-BDEPEND="
- virtual/pkgconfig
- doc? (
- app-doc/doxygen
- dev-texlive/texlive-bibtexextra
- dev-texlive/texlive-fontsextra
- dev-texlive/texlive-fontutils
- dev-texlive/texlive-latex
- dev-texlive/texlive-latexextra
- )
- test? ( dev-util/cppunit )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-use-gnuinstalldirs.patch"
- "${FILESDIR}/${P}-use-pkgconfig-for-ilmbase-and-openexr.patch"
- "${FILESDIR}/${PN}-4.0.2-fix-const-correctness-for-unittest.patch"
- "${FILESDIR}/${PN}-4.0.2-fix-build-docs.patch"
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local myprefix="${EPREFIX}/usr/"
-
- local version
- if use abi3-compat; then
- version=3
- elif use abi4-compat; then
- version=4
- elif use abi5-compat; then
- version=5
- else
- die "Openvdb ABI version not specified"
- fi
-
- local mycmakeargs=(
- -DBLOSC_LOCATION="${myprefix}"
- -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
- -DGLFW3_LOCATION="${myprefix}"
- -DOPENVDB_ABI_VERSION_NUMBER="${version}"
- -DOPENVDB_BUILD_DOCS=$(usex doc)
- -DOPENVDB_BUILD_PYTHON_MODULE=$(usex python)
- -DOPENVDB_BUILD_UNITTESTS=$(usex test)
- -DOPENVDB_ENABLE_RPATH=OFF
- -DTBB_LOCATION="${myprefix}"
- -DUSE_GLFW3=ON
- )
-
- use python && mycmakeargs+=( -DPYOPENVDB_INSTALL_DIRECTORY="$(python_get_sitedir)" )
- use test && mycmakeargs+=( -DCPPUNIT_LOCATION="${myprefix}" )
-
- cmake_src_configure
-}