summaryrefslogtreecommitdiff
path: root/media-gfx/openvdb/openvdb-10.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-06 00:30:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-06 00:30:33 +0100
commit9323524b4d44f4ec3dc923bd8e9ea04bdde8a067 (patch)
tree8ca7b8c58d4e70389d5d4672ebd86cb475cf9f80 /media-gfx/openvdb/openvdb-10.0.1.ebuild
parent8c11cf748cc296d6338a189106a8cc9e3a1e0948 (diff)
gentoo auto-resync : 06:04:2024 - 00:30:33
Diffstat (limited to 'media-gfx/openvdb/openvdb-10.0.1.ebuild')
-rw-r--r--media-gfx/openvdb/openvdb-10.0.1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/media-gfx/openvdb/openvdb-10.0.1.ebuild b/media-gfx/openvdb/openvdb-10.0.1.ebuild
index 287893b0cff4..5a0a42c5aed3 100644
--- a/media-gfx/openvdb/openvdb-10.0.1.ebuild
+++ b/media-gfx/openvdb/openvdb-10.0.1.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
-inherit cmake cuda llvm python-single-r1
+inherit cmake cuda flag-o-matic llvm python-single-r1
DESCRIPTION="Library for the efficient manipulation of volumetric data"
HOMEPAGE="https://www.openvdb.org"
@@ -100,6 +100,12 @@ src_prepare() {
}
src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/926820
+ # https://github.com/AcademySoftwareFoundation/openvdb/issues/1784
+ append-flags -fno-strict-aliasing
+ filter-lto
+
local myprefix="${EPREFIX}/usr/"
local version