summaryrefslogtreecommitdiff
path: root/media-gfx/opentoonz
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/opentoonz
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/opentoonz')
-rw-r--r--media-gfx/opentoonz/Manifest4
-rw-r--r--media-gfx/opentoonz/files/opentoonz-1.1.2-gcc6-no-throw-in-destructors.patch38
-rw-r--r--media-gfx/opentoonz/metadata.xml15
-rw-r--r--media-gfx/opentoonz/opentoonz-1.1.2.ebuild93
4 files changed, 150 insertions, 0 deletions
diff --git a/media-gfx/opentoonz/Manifest b/media-gfx/opentoonz/Manifest
new file mode 100644
index 000000000000..b1a0f3fab540
--- /dev/null
+++ b/media-gfx/opentoonz/Manifest
@@ -0,0 +1,4 @@
+AUX opentoonz-1.1.2-gcc6-no-throw-in-destructors.patch 1469 SHA256 cafb0e94d726f1ba251ecc6985bb9892876bfcf1c8f5e485970f314a091d4d0b SHA512 c11194c06df6dc2e2ce18f3c6863c19191793512672779a2b5d4df2e2b59348dd4c71c7ab887546b96943e97e0257b3aa152f45aa53a3e5ed95008fa3d6b59d5 WHIRLPOOL b21e700b376327b67fefcac8fa99ab037885a7ee66cc301c5796774a4121b5d3402a581f5c624a6b309ed75115f3ae7959c8efd03efe612aa9fa39a79f471dae
+DIST opentoonz-1.1.2.tar.gz 36777909 SHA256 e9943abbd49befb5c8963fd7cb744b6c5b93a4faa02c8564610b848d189ea029 SHA512 800a741cb40e7dede79ef92705fc8fe3a23524c8a4397c30f80a81a7513c98606fb1bb5574188969ba08cfe8995d679f9fc5ecb696a6ac14c48aa2646a2c871e WHIRLPOOL 2664e8f087163c4db3413135c7943d290088c116f91f07d414838b3efa2039fae2cf8e1fc1bf1521de580dc8d561cf16c4aee34cf165b2fd920ec02456e8b404
+EBUILD opentoonz-1.1.2.ebuild 2152 SHA256 e70645b975a2840614b6e8bd6e20951af9107be51b5d3c5e4e6221bb4b74c3b3 SHA512 62ca55a27d0e4ca42f274747b530221e003e67774fb822969f1b7e4e77eb80b961894a6362c45633c642dcbb1e35572ca77056d7cf43fede9f632789bb53aa35 WHIRLPOOL 8da5f434fd11de83f53e23574acdec12b9ad4d4909e8bd3d129bace379aff540e21410b11c09a63053589f94c13d88a0dc08b70cbeb76d3cb64cfadd96d05b9e
+MISC metadata.xml 453 SHA256 299ac9fa6e581f7c3aac4211ad063b7ecf3115d2741c4b7c00e4f3e95d149e2e SHA512 227ed636186b559a5c4fe8728bc8ad2fa519177451f61c6cc67e20be3f8b071715fe38c274956cc987c3c2a49a25b7c7ca61280608871861c0007c558c016d6f WHIRLPOOL f2c00995267edad6754fe287bf153b40ad5bc18d2c714a27b5225b2535323d5d03ee34248cf89f5d6fc3cbeff2d64792678b26f151e5a6c6e4ec4163b48dea34
diff --git a/media-gfx/opentoonz/files/opentoonz-1.1.2-gcc6-no-throw-in-destructors.patch b/media-gfx/opentoonz/files/opentoonz-1.1.2-gcc6-no-throw-in-destructors.patch
new file mode 100644
index 000000000000..ad0e5a2758ea
--- /dev/null
+++ b/media-gfx/opentoonz/files/opentoonz-1.1.2-gcc6-no-throw-in-destructors.patch
@@ -0,0 +1,38 @@
+Bug: https://bugs.gentoo.org/show_bug.cgi?id=612938
+
+From ae91dbad8c33b35ea564d235c8eba63adfcc0fef Mon Sep 17 00:00:00 2001
+From: Peter-Levine <plevine457@gmail.com>
+Date: Wed, 31 May 2017 04:49:36 -0400
+Subject: [PATCH] Don't allow throw() in destructors (#1182)
+
+---
+ toonz/sources/image/3gp/tiio_3gp_proxy.cpp | 2 --
+ toonz/sources/image/mov/tiio_mov_proxy.cpp | 2 --
+ 2 files changed, 4 deletions(-)
+
+diff --git a/toonz/sources/image/3gp/tiio_3gp_proxy.cpp b/toonz/sources/image/3gp/tiio_3gp_proxy.cpp
+index d1bd79717..03140f695 100644
+--- a/toonz/sources/image/3gp/tiio_3gp_proxy.cpp
++++ b/toonz/sources/image/3gp/tiio_3gp_proxy.cpp
+@@ -138,8 +138,6 @@ TLevelWriter3gp::~TLevelWriter3gp() {
+ QString res;
+
+ stream << (msg << QString("$closeLW3gp") << m_id);
+- if (tipc::readMessage(stream, msg) != "ok")
+- throw TException("Unable to write file");
+ }
+
+ //------------------------------------------------------------------
+diff --git a/toonz/sources/image/mov/tiio_mov_proxy.cpp b/toonz/sources/image/mov/tiio_mov_proxy.cpp
+index 260bbb196..6be067c01 100644
+--- a/toonz/sources/image/mov/tiio_mov_proxy.cpp
++++ b/toonz/sources/image/mov/tiio_mov_proxy.cpp
+@@ -206,8 +206,6 @@ TLevelWriterMov::~TLevelWriterMov() {
+ QString res;
+
+ stream << (msg << QString("$closeLWMov") << m_id);
+- if (tipc::readMessage(stream, msg) != "ok")
+- throw TException("Unable to write file");
+ }
+
+ //------------------------------------------------------------------
diff --git a/media-gfx/opentoonz/metadata.xml b/media-gfx/opentoonz/metadata.xml
new file mode 100644
index 000000000000..83ff81ea39b7
--- /dev/null
+++ b/media-gfx/opentoonz/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>otakuto.gentoo@gmail.com</email>
+ <name>Tact Yoshida</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">opentoonz/opentoonz</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/media-gfx/opentoonz/opentoonz-1.1.2.ebuild b/media-gfx/opentoonz/opentoonz-1.1.2.ebuild
new file mode 100644
index 000000000000..ed5cd3d6884d
--- /dev/null
+++ b/media-gfx/opentoonz/opentoonz-1.1.2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="An open-source full-featured 2D animation creation software"
+HOMEPAGE="https://github.com/opentoonz/opentoonz"
+SRC_URI="https://github.com/opentoonz/opentoonz/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD libtiff"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-arch/lz4:=
+ >=dev-libs/boost-1.55.0:=
+ dev-libs/lzo:2=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtmultimedia:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtopengl:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtscript:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+ media-libs/freeglut:=
+ media-libs/freetype:2=
+ media-libs/glew:=
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:=
+ media-libs/libsdl2:=
+ sci-libs/blas-reference:=
+ >=sci-libs/superlu-4.1:=
+ sys-libs/zlib:=
+ virtual/libusb:=
+ virtual/opengl
+"
+DEPEND="
+ $RDEPEND
+ virtual/pkgconfig
+ dev-qt/linguist-tools:5
+"
+
+CMAKE_USE_DIR="${S}"/toonz/sources
+
+PATCHES=( "${FILESDIR}"/${P}-gcc6-no-throw-in-destructors.patch )
+
+src_configure()
+{
+ local mycmakeargs=(
+ -DTIFF_LIBRARY="${S}/thirdparty/tiff-4.0.3/libtiff/.libs/libtiff.a"
+ -DSUPERLU_INCLUDE_DIR="${EPREFIX%/}/usr/include/superlu"
+ -DLZO_INCLUDE_DIR="${EPREFIX%/}/usr/include/lzo"
+ -DCMAKE_SKIP_RPATH=ON
+ )
+
+ # The upstream uses their own modified libtiff
+ # See: https://github.com/opentoonz/opentoonz/blob/master/doc/how_to_build_linux.md#building-libtiff
+ cd thirdparty/tiff-4.0.3 || die
+ econf \
+ --with-pic \
+ --disable-jbig \
+ --enable-static \
+ --disable-shared
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cd "${S}"/thirdparty/tiff-4.0.3 || die
+ emake
+
+ cmake-utils_src_compile
+}
+
+pkg_postinst()
+{
+ elog "It is supposedly optional but some files are"
+ elog "actually required to run the executable properly."
+ elog
+ elog "The .config/OpenToonz/ directory in your home folder"
+ elog "will contain your settings, work and other files."
+ elog
+ elog "We need to create it from the command-line:"
+ elog
+ elog "$ mkdir -p \$HOME/.config/OpenToonz"
+ elog "$ cp -r /usr/share/opentoonz/stuff/ \$HOME/.config/OpenToonz/"
+}