summaryrefslogtreecommitdiff
path: root/media-gfx/opencsg/opencsg-1.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-11 17:14:47 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-11 17:14:47 +0000
commit25e5a6599437664a3eff8d9f8a966adc896e09e8 (patch)
tree67ef90a99446e1fee47c4ebb4c8c3a8175b41913 /media-gfx/opencsg/opencsg-1.6.0.ebuild
parent24b2471760a35870c85ca752666bcb66120289af (diff)
gentoo auto-resync : 11:12:2023 - 17:14:47
Diffstat (limited to 'media-gfx/opencsg/opencsg-1.6.0.ebuild')
-rw-r--r--media-gfx/opencsg/opencsg-1.6.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/media-gfx/opencsg/opencsg-1.6.0.ebuild b/media-gfx/opencsg/opencsg-1.6.0.ebuild
new file mode 100644
index 000000000000..7afafcd37947
--- /dev/null
+++ b/media-gfx/opencsg/opencsg-1.6.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit qmake-utils
+
+MY_P="OpenCSG-${PV}"
+
+DESCRIPTION="The Constructive Solid Geometry rendering library"
+HOMEPAGE="https://www.opencsg.org"
+SRC_URI="https://www.opencsg.org/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2+"
+SLOT="0/1.6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="doc"
+RESTRICT="test"
+
+RDEPEND="
+ virtual/opengl
+"
+
+# qtgui is needed for opengles2 feature by
+# /usr/lib64/qt5/mkspecs/feature/unix/opengl.prf
+DEPEND="${RDEPEND}
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+"
+
+DOCS=( build.txt changelog.txt )
+
+PATCHES=( "${FILESDIR}"/${PN}-1.6.0-includepath.patch )
+
+src_configure() {
+ eqmake5 opencsg.pro INSTALLDIR="${EPREFIX}/usr" LIBDIR="$(get_libdir)"
+}
+
+src_compile() {
+ # rebuild Makefiles in subdirs
+ emake INSTALLDIR="${EPREFIX}/usr" LIBDIR="$(get_libdir)" qmake_all
+ emake sub-src
+}
+
+src_install() {
+ emake -C src INSTALL_ROOT="${ED}" install
+ use doc && local HTML_DOCS=( doc/. )
+ einstalldocs
+}