summaryrefslogtreecommitdiff
path: root/media-gfx/mcomix
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/mcomix
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/mcomix')
-rw-r--r--media-gfx/mcomix/Manifest5
-rw-r--r--media-gfx/mcomix/mcomix-1.2.1.ebuild69
-rw-r--r--media-gfx/mcomix/metadata.xml15
3 files changed, 89 insertions, 0 deletions
diff --git a/media-gfx/mcomix/Manifest b/media-gfx/mcomix/Manifest
new file mode 100644
index 000000000000..3c7c61c45419
--- /dev/null
+++ b/media-gfx/mcomix/Manifest
@@ -0,0 +1,5 @@
+DIST mcomix-1.2.1.tar.bz2 571128 SHA256 7e43159dc585bc9bc31970a44bd2b4e42c303660c4c8cf7f0eda413a6f72fa3b SHA512 efa4d57edc3a48d9e711767fb3e233ef9b334ff8ba467999e572e60ed747a4ee4aa420c8aa7788b16d7eb6e0901d454d6a405fcec47a8c74098a49491e915cd0 WHIRLPOOL cabebccb5793bdd78686c22448688826bc4ba7b9e422e3aa712f0930b8e8029721cf48bbe4e8d06e34c8f76515785ff259d08a7021e60beb1719c9b35d356619
+EBUILD mcomix-1.2.1.ebuild 1691 SHA256 8995b30d3101d04810939afc6066ead2807e6d4889a8eebc1dba46c337fdd66d SHA512 515b9f409c1e0c8a6e5f6dbf13dc91d27bed8489c94850b6b363b6ea393bfdd9bcbbda34a4efbc47c38340584909babf548eccd3321738d5b846b2fb3cea27fe WHIRLPOOL 7c0bf9ada2bf5cf8177d1f18c5b8b5895b58c2834e52060808404e5159d1ff4a3bc0dc8900988ad3c23cc34e498100b77bc240986087e13fd39dae488b77cfc0
+MISC ChangeLog 3296 SHA256 75e4b654f67608de2fe4acbeeb0454fd12bcb8ba46e8bf35ad9c3fe883282647 SHA512 360ac021cb29203e1102ad15d3ba7e9397e399146d5ef65d4504abd9f7d971cc837a094155569ddc56ec79c10958aee0763b8717bc49de010d9746fdd366080d WHIRLPOOL 2213eb86752082f2a41bf0a6399db46ed3c891c4a854f458a43cca54820ac2ee92c7991edacd7de160f10e8ab7dc4647c58d3b1b6dcd04af11064e9cfa8a4400
+MISC ChangeLog-2015 3945 SHA256 38e0bb4183173d46cc341676466b59b17fd4de9c0e95473459fbb5eb113b2094 SHA512 4e5aee52150c70f4bb6213e3d11f29937afe14c5965acbc2ee16bfee1a44b825f828369ad8c5545476efcb82edc0e58d6d636c1eefa4573b5b6167b0bb4dc10b WHIRLPOOL f7f94e4465722a793fa83d8cf3cfcf6f55c21320b8d16f8eda4fa464b2103fdb6a32cc717e4de7879a19ef7b77c5ad5cb76d94c1f0dd5b4746f8a38564d6f33a
+MISC metadata.xml 453 SHA256 3b2d513e2192e8b48289fb84e2af9f28dad3062ce45af735b5b063bf90ebd1c9 SHA512 7953a4c071cb2d35a62d6455ff1edccd141ac0d950df64964b60d785286387aa7bfa216f83cc257896a0470d8a43825a95ab25ab60557326bb2227975743ccce WHIRLPOOL 70d1bec1d3c305ace6da8954e7ae6508797ebf79da75e8c199cf60207f7556f3c8379d21010921c986dd623368bbaf7cfe042fe785ecfca9232456820004ed0e
diff --git a/media-gfx/mcomix/mcomix-1.2.1.ebuild b/media-gfx/mcomix/mcomix-1.2.1.ebuild
new file mode 100644
index 000000000000..dc954fa35aa9
--- /dev/null
+++ b/media-gfx/mcomix/mcomix-1.2.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+PLOCALES="ca cs de el es fa fr gl he hr hu id it ja ko nl pl pt_BR ru sv uk zh_CN zh_TW"
+
+inherit distutils-r1 fdo-mime l10n
+
+DESCRIPTION="A fork of comix, a GTK image viewer for comic book archives"
+HOMEPAGE="https://sourceforge.net/p/mcomix/wiki/Home/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ >=dev-python/pygtk-2.14[${PYTHON_USEDEP}]
+ virtual/jpeg
+ dev-python/pillow[${PYTHON_USEDEP}]
+ x11-libs/gdk-pixbuf
+ !media-gfx/comix"
+
+DOCS=( ChangeLog README )
+
+src_prepare() {
+ local checklocales
+ for l in $(find "${S}"/mcomix/messages/* -maxdepth 0 -type d);
+ do checklocales+="$(basename $l) "
+ done
+
+ [[ ${PLOCALES} == ${checklocales% } ]] \
+ || eqawarn "Update to PLOCALES=\"${checklocales% }\""
+
+ my_rm_loc() {
+ rm -rf "${S}/mcomix/messages/${1}/LC_MESSAGES" || die
+ rmdir "${S}/mcomix/messages/${1}" || die
+ }
+
+ l10n_for_each_disabled_locale_do my_rm_loc
+
+ distutils-r1_src_prepare
+}
+
+pkg_postinst() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+ echo
+ elog "Additional packages are required to open the most common comic archives:"
+ elog
+ elog " cbr: app-arch/unrar"
+ elog " cbz: app-arch/unzip"
+ elog
+ elog "You can also add support for 7z or LHA archives by installing"
+ elog "app-arch/p7zip or app-arch/lha. Install app-text/mupdf for"
+ elog "pdf support."
+ echo
+}
+
+pkg_postrm() {
+ fdo-mime_mime_database_update
+ fdo-mime_desktop_database_update
+}
diff --git a/media-gfx/mcomix/metadata.xml b/media-gfx/mcomix/metadata.xml
new file mode 100644
index 000000000000..a9a36dd4d75c
--- /dev/null
+++ b/media-gfx/mcomix/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>rhill@gentoo.org</email>
+ <name>Ryan Hill</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>graphics@gentoo.org</email>
+ <name>Gentoo Graphics Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">mcomix</remote-id>
+ </upstream>
+</pkgmetadata>