summaryrefslogtreecommitdiff
path: root/media-gfx/mcomix/mcomix-2.0.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-17 19:55:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-17 19:55:04 +0100
commitd941e0a66c717c1f67ae35cf31afdfcbf7f7acbb (patch)
tree6606e5c9423367645538e1d0423cb35b1dbcfa16 /media-gfx/mcomix/mcomix-2.0.2-r1.ebuild
parentfe7238eca1d510cb096bf290978af72ba6607930 (diff)
gentoo auto-resync : 17:10:2022 - 19:55:04
Diffstat (limited to 'media-gfx/mcomix/mcomix-2.0.2-r1.ebuild')
-rw-r--r--media-gfx/mcomix/mcomix-2.0.2-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/media-gfx/mcomix/mcomix-2.0.2-r1.ebuild b/media-gfx/mcomix/mcomix-2.0.2-r1.ebuild
new file mode 100644
index 000000000000..8a55da1c0833
--- /dev/null
+++ b/media-gfx/mcomix/mcomix-2.0.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1 optfeature xdg
+
+DESCRIPTION="GTK image viewer for comic book archives"
+HOMEPAGE="http://mcomix.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE=""
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=dev-python/pillow-6.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pycairo-1.16.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.36.0[${PYTHON_USEDEP}]
+ media-libs/libjpeg-turbo:0
+ x11-libs/gtk+:3[introspection]"
+BDEPEND="sys-devel/gettext"
+# Most tests are quite old and do not run
+RESTRICT="test"
+
+src_prepare() {
+ default
+
+ # Uncompress man page
+ gunzip mcomix.1.gz || die
+ sed -e "s/mcomix.1.gz/mcomix.1/" -i setup.py || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ optfeature "RAR (.cbr) archives" app-arch/unrar
+ optfeature "7Zip archives" app-arch/p7zip
+ optfeature "LHA/LZA archives" app-arch/lha
+ optfeature "PDF files" app-text/mupdf
+}