summaryrefslogtreecommitdiff
path: root/media-gfx/mandelbulber/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-02-11 16:09:52 +0000
commitf78108598211053d41752a83e0345441bb9014ae (patch)
treedd2fc7ae0a1aea7bda4942ab0c453d1e55284b37 /media-gfx/mandelbulber/files
parentdc45b83b28fb83e9659492066e347b8dc60bc9e3 (diff)
gentoo resync : 11.02.2018
Diffstat (limited to 'media-gfx/mandelbulber/files')
-rw-r--r--media-gfx/mandelbulber/files/mandelbulber-1.11-qa.patch37
-rw-r--r--media-gfx/mandelbulber/files/mandelbulber-1.12.1-memcpy_and_memset.patch22
2 files changed, 0 insertions, 59 deletions
diff --git a/media-gfx/mandelbulber/files/mandelbulber-1.11-qa.patch b/media-gfx/mandelbulber/files/mandelbulber-1.11-qa.patch
deleted file mode 100644
index f457c1902c8f..000000000000
--- a/media-gfx/mandelbulber/files/mandelbulber-1.11-qa.patch
+++ /dev/null
@@ -1,37 +0,0 @@
---- a/makefiles/makefile
-+++ b/makefiles/makefile
-@@ -5,6 +5,7 @@
- -include ../makefile.init
-
- RM := rm -rf
-+CXX ?= g++
-
- # All of the sources participating in the build are defined here
- -include sources.mk
-@@ -44,7 +45,7 @@
- mandelbulber: $(OBJS) $(USER_OBJS)
- @echo 'Building target: $@'
- @echo 'Invoking: GCC C++ Linker'
-- g++ -o"mandelbulber" -L/usr/lib/x86_64-linux-gnu/ $(OBJS) $(USER_OBJS) $(LIBS) `pkg-config --libs gtk+-2.0 gthread-2.0`
-+ $(CXX) $(LDFLAGS) -o"mandelbulber" -L/usr/lib/x86_64-linux-gnu/ $(OBJS) $(USER_OBJS) $(LIBS) `pkg-config --libs gtk+-2.0 gthread-2.0`
- @echo 'Finished building target: $@'
- @echo ' '
-
---- a/makefiles/src/subdir.mk
-+++ b/makefiles/src/subdir.mk
-@@ -63,12 +63,14 @@
- ./src/undo.d \
- ./src/cl_support.d
-
-+CXX ?= g++
-+CXXFLAGS ?= -O2 -fast-math
-
- # Each subdirectory must supply rules for building sources it contributes
- src/%.o: ../src/%.cpp
- @echo 'Building file: $<'
- @echo 'Invoking: GCC C++ Compiler'
-- g++ -O2 -ffast-math -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o"$@" "$<"
-+ $(CXX) $(CXXFLAGS) -Wall -c -fmessage-length=0 `pkg-config --cflags gtk+-2.0 gthread-2.0;` -MMD -MP -MF"$(@:%.o=%.d)" -MT"$(@:%.o=%.d)" -o"$@" "$<"
- @echo 'Finished building: $<'
- @echo ' '
-
diff --git a/media-gfx/mandelbulber/files/mandelbulber-1.12.1-memcpy_and_memset.patch b/media-gfx/mandelbulber/files/mandelbulber-1.12.1-memcpy_and_memset.patch
deleted file mode 100644
index 43fb0b982dbd..000000000000
--- a/media-gfx/mandelbulber/files/mandelbulber-1.12.1-memcpy_and_memset.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-http://bugs.gentoo.org/464972
-
---- src/texture.cpp
-+++ src/texture.cpp
-@@ -5,6 +5,7 @@
- * Author: krzysztof
- */
- #include <stdio.h>
-+#include <string.h>
- #include "texture.hpp"
- #include "files.h"
-
---- src/timeline.cpp
-+++ src/timeline.cpp
-@@ -6,6 +6,7 @@
- */
-
- #include <cstdlib>
-+#include <cstring>
-
- #include "timeline.hpp"
- #include "files.h"