summaryrefslogtreecommitdiff
path: root/media-gfx/maim/maim-5.7.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-28 14:56:07 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-28 14:56:07 +0100
commit852755c64dfdf54c5457f631bfc34ced2e58fdb8 (patch)
tree433ad60942518e52456637e8a45088b60bb43b89 /media-gfx/maim/maim-5.7.4.ebuild
parentd248a331ab8127c4d49fc052be26bffe0927a33a (diff)
gentoo auto-resync : 28:08:2022 - 14:56:07
Diffstat (limited to 'media-gfx/maim/maim-5.7.4.ebuild')
-rw-r--r--media-gfx/maim/maim-5.7.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/media-gfx/maim/maim-5.7.4.ebuild b/media-gfx/maim/maim-5.7.4.ebuild
new file mode 100644
index 000000000000..c97126c54b14
--- /dev/null
+++ b/media-gfx/maim/maim-5.7.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Commandline tool to take screenshots of the desktop"
+HOMEPAGE="https://github.com/naelstrof/maim"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/naelstrof/maim.git"
+else
+ SRC_URI="https://github.com/naelstrof/maim/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+ MIT"
+SLOT="0"
+IUSE="icu"
+
+DEPEND="
+ media-libs/libjpeg-turbo:=
+ media-libs/libpng:0=
+ media-libs/libwebp:=
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ >=x11-misc/slop-7.5:=
+ icu? ( dev-libs/icu:= )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DMAIM_UNICODE=$(usex icu)
+ )
+ cmake_src_configure
+}