summaryrefslogtreecommitdiff
path: root/media-gfx/kio-ps-thumbnailer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-16 12:22:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-16 12:22:56 +0100
commit2ca31eebd5b7496656193e0aa6ae39200d69a017 (patch)
tree6cf0c8f4ce90a3960c27acf45011134fb674dd62 /media-gfx/kio-ps-thumbnailer
parent3ad1879f00b279af69d6b9cd3ef97a2a7496d734 (diff)
gentoo auto-resync : 16:08:2024 - 12:22:56
Diffstat (limited to 'media-gfx/kio-ps-thumbnailer')
-rw-r--r--media-gfx/kio-ps-thumbnailer/Manifest5
-rw-r--r--media-gfx/kio-ps-thumbnailer/kio-ps-thumbnailer-23.08.5.ebuild43
-rw-r--r--media-gfx/kio-ps-thumbnailer/kio-ps-thumbnailer-24.05.2.ebuild43
-rw-r--r--media-gfx/kio-ps-thumbnailer/metadata.xml12
4 files changed, 103 insertions, 0 deletions
diff --git a/media-gfx/kio-ps-thumbnailer/Manifest b/media-gfx/kio-ps-thumbnailer/Manifest
new file mode 100644
index 000000000000..a8a91e777bb9
--- /dev/null
+++ b/media-gfx/kio-ps-thumbnailer/Manifest
@@ -0,0 +1,5 @@
+DIST kdegraphics-thumbnailers-23.08.5.tar.xz 49436 BLAKE2B 943ad7bd93ca5e4d80854869d4d97f7121d259a82062afb7781d1845e94cbc6ea1732aff3d3476eb6db5ffe54f8f97b352ef8977ebdccc2b173594dd3cbccd6f SHA512 77c328e9532fbd12548d4d219d6da2ad369ee14825d3cf5d142ec11afb842640e1fd01e7e1f911147c93e7e93893b9ae10be66b3d568866ed8985b5e5b38663f
+DIST kdegraphics-thumbnailers-24.05.2.tar.xz 48756 BLAKE2B f5c2932c89fe38933c764171c31edfc0c11b7d6a34170e283a5f7ebc221866a2005897e580f1076b4a8bd9438d2fc39ff4b5da99abe90ce41c7465f35b7f6479 SHA512 eafc1eaf48fe7fef2556b1ba39beec0032b3fbc3ad01856517c86e6d56a2d24c488db9ca6cd9669a5b70c16ce44b6006c0a9e48216af08d03fbd805973158503
+EBUILD kio-ps-thumbnailer-23.08.5.ebuild 894 BLAKE2B 41158ee5646f914c5aacc1aacb9db691eb81f18a8b0e012fa9464d47fb66204f1804af9141eedbab4e485506d6de6c3299adf98f28f728b09adec4d0327e4211 SHA512 62a5f24fbce1bf401952ad175d89d498969d9d2852df9d09bd598875e4e3c1377bfc81b945bb4d9cf1479ee2501511c4c735fe9a8da9950d524e82c0f39e563b
+EBUILD kio-ps-thumbnailer-24.05.2.ebuild 891 BLAKE2B 18a07a5b8a6fa9f14e807c44714d741ebde774d9f7d5bb5d7b5387c266ac22b846c4c09008bfe04c45495b3238f927f9e197776cfe374015dd084b5b97b71b51 SHA512 cdeb6e581c911d886a557f4bc28fb9a42117f041482ae5ca5664b615ca17e95258abad45f05d7d1c50f46e4c17442818d1d7d222f68d839b411cc9499e339b7a
+MISC metadata.xml 395 BLAKE2B e3794bfe43e720ba54df37c3174ab9754e3c09ff986b80ce66511bf6fb739344eb49d4cf1e6daae63eb13d11deb82407945f48e4dd186905477155a624dd0787 SHA512 50a4cbb59e7411ccbdf6a135877b3103bee5dd58511b9030556df9a076c806032302e02ee067d917ba6b1d7e6a8233d93b3335ac21a14c59c00240150013d6b5
diff --git a/media-gfx/kio-ps-thumbnailer/kio-ps-thumbnailer-23.08.5.ebuild b/media-gfx/kio-ps-thumbnailer/kio-ps-thumbnailer-23.08.5.ebuild
new file mode 100644
index 000000000000..c7a6c0dadbeb
--- /dev/null
+++ b/media-gfx/kio-ps-thumbnailer/kio-ps-thumbnailer-23.08.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_NAME="kdegraphics-thumbnailers"
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm gear.kde.org
+
+DESCRIPTION="KIO thumbnail generator for DVI, EPS, PDF and PS files"
+HOMEPAGE="https://apps.kde.org/kdegraphics_thumbnailers/"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ !<kde-apps/thumbnailers-23.08.5-r1:5
+ app-text/dvipsk
+ app-text/ghostscript-gpl
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_kf_module Archive
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_blend=OFF
+ -DDISABLE_MOBIPOCKET=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_QMobipocket=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_KF5KExiv2=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_KF5KDcraw=ON
+ )
+
+ ecm_src_configure
+}
diff --git a/media-gfx/kio-ps-thumbnailer/kio-ps-thumbnailer-24.05.2.ebuild b/media-gfx/kio-ps-thumbnailer/kio-ps-thumbnailer-24.05.2.ebuild
new file mode 100644
index 000000000000..30266f3432c9
--- /dev/null
+++ b/media-gfx/kio-ps-thumbnailer/kio-ps-thumbnailer-24.05.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_NAME="kdegraphics-thumbnailers"
+KFMIN=6.3.0
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="KIO thumbnail generator for DVI, EPS, PDF and PS files"
+HOMEPAGE="https://apps.kde.org/kdegraphics_thumbnailers/"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui]
+ >=kde-frameworks/kio-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ !<kde-apps/thumbnailers-24.05.2-r1:6
+ app-text/dvipsk
+ app-text/ghostscript-gpl
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_kf_module Archive
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_blend=OFF
+ -DDISABLE_MOBIPOCKET=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_QMobipocket6=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_KExiv2Qt6=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_KDcrawQt6=ON
+ )
+
+ ecm_src_configure
+}
diff --git a/media-gfx/kio-ps-thumbnailer/metadata.xml b/media-gfx/kio-ps-thumbnailer/metadata.xml
new file mode 100644
index 000000000000..9d38b76b7d3d
--- /dev/null
+++ b/media-gfx/kio-ps-thumbnailer/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://bugs.kde.org/</bugs-to>
+ <remote-id type="kde-invent">graphics/kdegraphics-thumbnailers</remote-id>
+ </upstream>
+</pkgmetadata>