summaryrefslogtreecommitdiff
path: root/media-gfx/kio-mobi-thumbnailer
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-16 12:22:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-16 12:22:56 +0100
commit2ca31eebd5b7496656193e0aa6ae39200d69a017 (patch)
tree6cf0c8f4ce90a3960c27acf45011134fb674dd62 /media-gfx/kio-mobi-thumbnailer
parent3ad1879f00b279af69d6b9cd3ef97a2a7496d734 (diff)
gentoo auto-resync : 16:08:2024 - 12:22:56
Diffstat (limited to 'media-gfx/kio-mobi-thumbnailer')
-rw-r--r--media-gfx/kio-mobi-thumbnailer/Manifest5
-rw-r--r--media-gfx/kio-mobi-thumbnailer/kio-mobi-thumbnailer-23.08.5.ebuild42
-rw-r--r--media-gfx/kio-mobi-thumbnailer/kio-mobi-thumbnailer-24.05.2.ebuild42
-rw-r--r--media-gfx/kio-mobi-thumbnailer/metadata.xml12
4 files changed, 101 insertions, 0 deletions
diff --git a/media-gfx/kio-mobi-thumbnailer/Manifest b/media-gfx/kio-mobi-thumbnailer/Manifest
new file mode 100644
index 000000000000..21a557fe332d
--- /dev/null
+++ b/media-gfx/kio-mobi-thumbnailer/Manifest
@@ -0,0 +1,5 @@
+DIST kdegraphics-thumbnailers-23.08.5.tar.xz 49436 BLAKE2B 943ad7bd93ca5e4d80854869d4d97f7121d259a82062afb7781d1845e94cbc6ea1732aff3d3476eb6db5ffe54f8f97b352ef8977ebdccc2b173594dd3cbccd6f SHA512 77c328e9532fbd12548d4d219d6da2ad369ee14825d3cf5d142ec11afb842640e1fd01e7e1f911147c93e7e93893b9ae10be66b3d568866ed8985b5e5b38663f
+DIST kdegraphics-thumbnailers-24.05.2.tar.xz 48756 BLAKE2B f5c2932c89fe38933c764171c31edfc0c11b7d6a34170e283a5f7ebc221866a2005897e580f1076b4a8bd9438d2fc39ff4b5da99abe90ce41c7465f35b7f6479 SHA512 eafc1eaf48fe7fef2556b1ba39beec0032b3fbc3ad01856517c86e6d56a2d24c488db9ca6cd9669a5b70c16ce44b6006c0a9e48216af08d03fbd805973158503
+EBUILD kio-mobi-thumbnailer-23.08.5.ebuild 853 BLAKE2B a0ecb37ceba30db48b953877dca2c9680338170854226f46872b06f4413de9cf77abd890697c0821ba5ba818b824be075d3662105d482b35cd57b6c9535e4ba0 SHA512 53c395c374c04a5464cfe74cb2dbab318a49ca403dc7522c1289207b29aea1cfc64c8127a3d30044341b6ea6edaa3c04b96e838c69b7cb3e8516281f08e6cef7
+EBUILD kio-mobi-thumbnailer-24.05.2.ebuild 849 BLAKE2B a667dfd2c60791e9f3e0b78d176b7a6f427b0306f1971a9b61910bfa32e358bc974175f5910383e28fcf82bbe54a46cdcc1ef142f22295ace438a1b84e6f4305 SHA512 e0214bf8f3312188f7ab582e10fc4e1889b2262d1ff4eb7965771e31f51ac4198c15edc958c49a706d04c7be620342dc5094ad64f50f6ae49f306f0e6aa2d919
+MISC metadata.xml 395 BLAKE2B e3794bfe43e720ba54df37c3174ab9754e3c09ff986b80ce66511bf6fb739344eb49d4cf1e6daae63eb13d11deb82407945f48e4dd186905477155a624dd0787 SHA512 50a4cbb59e7411ccbdf6a135877b3103bee5dd58511b9030556df9a076c806032302e02ee067d917ba6b1d7e6a8233d93b3335ac21a14c59c00240150013d6b5
diff --git a/media-gfx/kio-mobi-thumbnailer/kio-mobi-thumbnailer-23.08.5.ebuild b/media-gfx/kio-mobi-thumbnailer/kio-mobi-thumbnailer-23.08.5.ebuild
new file mode 100644
index 000000000000..e71e4c75f259
--- /dev/null
+++ b/media-gfx/kio-mobi-thumbnailer/kio-mobi-thumbnailer-23.08.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_NAME="kdegraphics-thumbnailers"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.106.0
+QTMIN=5.15.9
+inherit ecm gear.kde.org
+
+DESCRIPTION="KIO thumbnail generator for Mobipocket files"
+HOMEPAGE="https://apps.kde.org/kdegraphics_thumbnailers/"
+
+LICENSE="GPL-2+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=kde-apps/kdegraphics-mobipocket-${PVCUT}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+"
+RDEPEND="${DEPEND}
+ !<kde-apps/thumbnailers-23.08.5-r1:5
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_kf_module Archive
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_ps=OFF
+ -DBUILD_blend=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_KF5KExiv2=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_KF5KDcraw=ON
+ )
+
+ ecm_src_configure
+}
diff --git a/media-gfx/kio-mobi-thumbnailer/kio-mobi-thumbnailer-24.05.2.ebuild b/media-gfx/kio-mobi-thumbnailer/kio-mobi-thumbnailer-24.05.2.ebuild
new file mode 100644
index 000000000000..0d90be2af4e2
--- /dev/null
+++ b/media-gfx/kio-mobi-thumbnailer/kio-mobi-thumbnailer-24.05.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_NAME="kdegraphics-thumbnailers"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.3.0
+QTMIN=6.6.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="KIO thumbnail generator for Mobipocket files"
+HOMEPAGE="https://apps.kde.org/kdegraphics_thumbnailers/"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui]
+ >=kde-apps/kdegraphics-mobipocket-${PVCUT}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ !<kde-apps/thumbnailers-24.05.2-r1:6
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_kf_module Archive
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_ps=OFF
+ -DBUILD_blend=OFF
+ -DCMAKE_DISABLE_FIND_PACKAGE_KExiv2Qt6=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_KDcrawQt6=ON
+ )
+
+ ecm_src_configure
+}
diff --git a/media-gfx/kio-mobi-thumbnailer/metadata.xml b/media-gfx/kio-mobi-thumbnailer/metadata.xml
new file mode 100644
index 000000000000..9d38b76b7d3d
--- /dev/null
+++ b/media-gfx/kio-mobi-thumbnailer/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>kde@gentoo.org</email>
+ <name>Gentoo KDE Project</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://bugs.kde.org/</bugs-to>
+ <remote-id type="kde-invent">graphics/kdegraphics-thumbnailers</remote-id>
+ </upstream>
+</pkgmetadata>