summaryrefslogtreecommitdiff
path: root/media-gfx/jhead/jhead-3.00.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /media-gfx/jhead/jhead-3.00.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'media-gfx/jhead/jhead-3.00.ebuild')
-rw-r--r--media-gfx/jhead/jhead-3.00.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/media-gfx/jhead/jhead-3.00.ebuild b/media-gfx/jhead/jhead-3.00.ebuild
new file mode 100644
index 000000000000..a2d8d93f35bf
--- /dev/null
+++ b/media-gfx/jhead/jhead-3.00.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Exif Jpeg camera setting parser and thumbnail remover"
+HOMEPAGE="http://www.sentex.net/~mwandel/jhead"
+SRC_URI="http://www.sentex.net/~mwandel/${PN}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+PATCHES=(
+ # bug 275200 - respect flags and use mktemp instead of mkstemp
+ "${FILESDIR}"/${PN}-2.90-mkstemp_respect_flags.patch
+)
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc *.txt
+ docinto html
+ dodoc *.html
+ doman ${PN}.1
+}